Support Troubles

Status
Not open for further replies.

shortwaver

Member
Premium Subscriber
Joined
Jan 20, 2012
Messages
208
Location
Lil Rhody
Greetings.

On June 5, I requested assistance on my account. My Ham Radio Bio shows that I am a Technician, and I asked for help changing that to General, as I could not find a way to do that myself. Five days later I received an email saying that they had changed my username to match my callsign. I did not request that. I followed up with several emails, but as of yet have not heard anything back in TEN days.

It's been over two weeks and the initial request has not been resolved yet. Is this normal? I just want my username back.
 

shortwaver

Member
Premium Subscriber
Joined
Jan 20, 2012
Messages
208
Location
Lil Rhody
Do any moderators here have any weight with people in support? Just asking because another week has gone by with no replies to my support request.

Very troubling since I've been a premium member for years and really liked the site.


Thanks
 

mikewazowski

Forums Manager/Global DB Admin
Staff member
Joined
Jun 26, 2001
Messages
11,854
Location
Central Ontario
Lindsay would be the one to help but I believe he's on the road at the moment.

Have a little more patience and hopefully he'll have some time to handle your request.
 

shortwaver

Member
Premium Subscriber
Joined
Jan 20, 2012
Messages
208
Location
Lil Rhody
Lindsay would be the one to help but I believe he's on the road at the moment.

Have a little more patience and hopefully he'll have some time to handle your request.
I was contacted and my username was fixed. Thanks again.
 
Status
Not open for further replies.
Top