DSDPlus TCP Protocol Error / Incompatible DSD+/FMPx versions

Joined
Feb 14, 2008
Messages
2,105
I get this error after updating to 2.256 and using FMPA 2.34. Anyone know a way to troubleshoot this? Thanks.

1598801592117.png
 

maus92

Member
Premium Subscriber
Joined
Jun 23, 2004
Messages
4,538
Location
Annapolis
What version did you update from? AFAIK, you must apply every update sequentially to make sure you have received / installed all updated files.
 

cg

Member
Premium Subscriber
Joined
Dec 13, 2000
Messages
3,563
Location
Connecticut
Verify that each file is in fact the newest one and you didn't overwrite one in error. When the program starts it shows in the activity windows. The latest FMPA is 2.36 according to the Notes file.

chris
 

thewraith2008

Member
Joined
Nov 22, 2016
Messages
1,114
The 'DSDPlus.event' log will tell you the version of DSD+ you where using at the beginning of each session.
 

thewraith2008

Member
Joined
Nov 22, 2016
Messages
1,114
Here is a current file versions list

Code:
------------------------------------------------------------------
                   File Ver.  Last FL version file was updated in
------------------------------------------------------------------
 - DSDPlus.exe      [2.256]   2.256
 - FMP.exe          [1.4t_]   1.101 - Public release - For reference only
 - FMP24.exe        [2.65_]   2.246
 - FMPA.exe         [2.36_]   2.246
 - FMP-Map.exe      [1.8__]   2.235
 - FMPP.exe         [1.13_]   2.246
 - LRRP.exe         [1.23_]   2.235
 - rtlsdr.dll       [?____]   2.197 - An updated version of the RTL driver [dated: 12th July 2016]
 - sdrplay_api.dll  [3.06?]   2.228 - An updated version of the SDRPlay RSP1 driver [dated: 26th November 2019]
 - Survey.exe       [1.7__]   2.235
 
Joined
Feb 14, 2008
Messages
2,105
Thanks. I went ahead and e-mailed DSD+ and they replied back with the files I needed. Got it working now.
 
Top