Ten-Tec RX350 Display Backlight Issues

Status
Not open for further replies.

mfn002

Member
Premium Subscriber
Joined
Apr 26, 2006
Messages
2,132
Location
Bryan, Texas
Ever since I got my (used) RX350 a few years ago, it has had issues with the backlight randomly flickering or going out entirely. When I first acquired it, the backlight didn't work at all. I then left it unplugged for a few months and just recently hooked it up again. It was at this point that the backlight came on but started fluctuating in brightness. It's not a big problem, but I am curious as to what could be causing it. Has anyone else encountered this problem?
 

Boombox

Member
Joined
Sep 2, 2012
Messages
886
I don't know much about that radio but it sounds like a bad or intermittent solder joint somewhere.

If the radio has a hardware light switch (doesn't look like it does from the picture), I'd check it. If the light switch is in conjunction with the power switch I'd check that. If the lights seem to be firmware operated, I'd check the solder connections that supply the power to the lights.

But if it's surface mount, be careful. Surface mount is easy to mess up. Trust me, I know (I almost wrecked the headphone jack of a PRD5 'cause the solder spots were all surface mount).

Might be worth it to have a shop look at it if you look inside and see everything's surface mount... or live with the intermittent lights.

Sounds like it's a good radio (with some useful features) from reading some reviews. One review (Ten-Tec RX-350 DSP HF Receiver Review - N9EWO -) mentioned some bad LCD's in later production runs but the guy may not have been referring to backlighting. The EHam reviews are positive.

I'd just take a look inside and see if the problem is something simple, like a loose cable to the lights or large solder spots that look easy to touch up with an iron. Otherwise, live with it or talk to a shop.... I'm sure others here who know the radio better will have a lot better info.

Good luck and Good DX with it either way.
 

mfn002

Member
Premium Subscriber
Joined
Apr 26, 2006
Messages
2,132
Location
Bryan, Texas
I just finished three and a half hours of listening to it, and it is pretty good (I got about 160 different frequencies today). After I mentioned the problem here, it went out and stayed out for the rest of the time I had it on. I doubt it is a loose solder joint, because it seems to do it even when I'm not touching it. When the backlight is on, it seems to fluctuate in brightness. I almost think its some sort of power fluctuation issue. It's not really a big deal, but it is somewhat annoying (but not nearly as bad as the VR-5000 I had that had missing pixels in the screen).
 

osros

Member
Feed Provider
Joined
Jun 12, 2003
Messages
212
Location
Gainesville, Texas
Have fond memories of my RX350 was a nice unit sold it in almost mint condition always thought the spectrum display was a bit slow and not of much use unless looking for strong broadcast stations but still nice to use.
 
Status
Not open for further replies.
Top