Trunk-Recorder P25 Phase 2 Site

Status
Not open for further replies.

cellphone

Silent key.
Premium Subscriber
Joined
Dec 28, 2002
Messages
1,811
Location
Ahwatukee, AZ (Phoenix)
Has anyone used Trunk-Recorder on a P25 Phase 2 site? I'm getting an odd behavior where the recorder is not tuning to the correct frequency:

Num [3] TG: 2404 Freq: 7.705187e+08 TDMA: true Slot: 0
recorder_1 | [2020-02-25 05:26:14.895730] (info) [mc-chand] TG: 2404 Freq: 7.662625e+08 Not Recording: no source covering Freq


Notice that the frequency next to talkgroup 2404 is 7.705187e+08 (correct frequency of 770.51875). However, there is an error stating that there is no source covering Freq 7.662625e+08 (incorrect frequency of 766.2625). My source is an airspy covering 768-778 MHz. If recorder_1 would tune the correct frequency, then I should be able to record.

I have not seen this issue with a P25 Phase 1 sites.
 

nick0909

Antenna flicker
Feed Provider
Joined
Jan 4, 2003
Messages
138
I just got a phase 2 system working last night on an airspy mini. No issues like that, except I noticed mine is reporting TDMA: false so maybe not a direct comparison.
 

mtindor

OH/WV DB Admin
Database Admin
Joined
Dec 5, 2006
Messages
10,606
Location
Carroll Co OH / EN90LN
Has anyone used Trunk-Recorder on a P25 Phase 2 site? I'm getting an odd behavior where the recorder is not tuning to the correct frequency:

Num [3] TG: 2404 Freq: 7.705187e+08 TDMA: true Slot: 0
recorder_1 | [2020-02-25 05:26:14.895730] (info) [mc-chand] TG: 2404 Freq: 7.662625e+08 Not Recording: no source covering Freq


Notice that the frequency next to talkgroup 2404 is 7.705187e+08 (correct frequency of 770.51875). However, there is an error stating that there is no source covering Freq 7.662625e+08 (incorrect frequency of 766.2625). My source is an airspy covering 768-778 MHz. If recorder_1 would tune the correct frequency, then I should be able to record.

I have not seen this issue with a P25 Phase 1 sites.

That is indeed odd. Can you post your config.json and a link to the system you are monitoring (presuming it is listed on RR) ?
 

mtindor

OH/WV DB Admin
Database Admin
Joined
Dec 5, 2006
Messages
10,606
Location
Carroll Co OH / EN90LN
Has anyone used Trunk-Recorder on a P25 Phase 2 site? I'm getting an odd behavior where the recorder is not tuning to the correct frequency:

Num [3] TG: 2404 Freq: 7.705187e+08 TDMA: true Slot: 0
recorder_1 | [2020-02-25 05:26:14.895730] (info) [mc-chand] TG: 2404 Freq: 7.662625e+08 Not Recording: no source covering Freq


Notice that the frequency next to talkgroup 2404 is 7.705187e+08 (correct frequency of 770.51875). However, there is an error stating that there is no source covering Freq 7.662625e+08 (incorrect frequency of 766.2625). My source is an airspy covering 768-778 MHz. If recorder_1 would tune the correct frequency, then I should be able to record.

I have not seen this issue with a P25 Phase 1 sites.

If you are monitoring AZ WINS - Yuma 1, you might want to make sure your center freq is set to something like center: 770.29375 . And I'm presuming that you are running modulation: qpsk .

Are you running the latest version of Trunk Recorder ( 3.1.2 ) ?

Mike

Mike
 

cellphone

Silent key.
Premium Subscriber
Joined
Dec 28, 2002
Messages
1,811
Location
Ahwatukee, AZ (Phoenix)
The System / Site I am trying to monitor is Maricopa County (P25) Site 134 Chandler/Mesa Simulcast

I am using the Docker install and was built on Monday. Below is the config.json (apiKey for upload to openmhz is x out). The system with the issue is the last system in the config. The other 4 systems in the config work great, but only have Phase 1 talkgroups.

{
"sources": [{
"center": 773000000.0,
"rate": 10000000.0,
"error": 0,
"squelch": -65,
"gain": 15,
"digitalRecorders": 40,
"driver": "osmosdr",
"device": "airspy",
"modulation": "qpsk"
}],
"systems": [{
"control_channels": [772106250, 770106250, 770356250, 772356250],
"type": "p25",
"talkgroupsFile": "./TG.csv",
"shortName": "phxrwc",
"apiKey": "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
}, {
"control_channels": [771918750, 773168750, 774168750, 774418750],
"type": "p25",
"talkgroupsFile": "./TG.csv",
"shortName": "rwcf",
"apiKey": "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
}, {
"control_channels": [769306250, 769556250, 769806250, 770056250],
"type": "p25",
"talkgroupsFile": "./TG.csv",
"shortName": "rwcsmtn",
"apiKey": "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
}, {
"control_channels": [774068750, 774318750],
"type": "p25",
"talkgroupsFile": "./AZWINSTG.csv",
"shortName": "azwinssmtn",
"apiKey": "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
}, {
"control_channels": [771331250, 771493750, 771706250, 771831250],
"type": "p25",
"talkgroupsFile": "./MCTG.csv",
"shortName": "mcchand",
"apiKey": "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
}],
"uploadServer": "https://api.openmhz.com"
 

mtindor

OH/WV DB Admin
Database Admin
Joined
Dec 5, 2006
Messages
10,606
Location
Carroll Co OH / EN90LN
I have seen all of the stuff you have uploading to OpenMHZ. You clearly know what you are doing. So I'm only going to guess that this could have something to do with the "T" modes in CSV files that you might download from RR or create. EVen though they are T on RR, I think you still have to have them specified as D in the CSV file. I remember testing a PII system a few weeks ago and couldn't get it to record for anything, and I believe it ended up being a case where I grabbed the talkgroup info from RR, massaged it, and used it in Trunk Recorder -- but I had T for the mode instead oF D. I believe when I switched them to D in the csv file used by Trunk Recorder, it started working.

So try that.

And, also consider adding the defaultMode option.

Here is a config.json working for me, along with a CSV file that has D for the mode instead of T

{
"sources": [{
"center": 771650000,
"rate": 2400000,
"error": 0,
"gain": 32.5,
"debugRecorders": 0,
"digitalRecorders": 8,
"digitalLevels": 8,
"modulation": "qpsk",
"driver": "osmosdr",
"device": "rtl=0"
}],
"systems": [{
"control_channels": [771193750, 771506250, 771831250],
"type": "p25",
"recordUnknown": true,
"hideEncrypted": true,
"hideUnknownTalkgroups": false,
"talkgroupsFile": "medinacounty.csv",
"shortName": "MedCo",
"uploadScript": "encode-local-sys-1.sh"
}],
"defaultMode": "digital",
"captureDir": "/home/radio/trunk-player/audio_files",
"frequencyFormat": "mhz",
"logFile": true
}
 

cellphone

Silent key.
Premium Subscriber
Joined
Dec 28, 2002
Messages
1,811
Location
Ahwatukee, AZ (Phoenix)
I had T for the mode instead oF D. I believe when I switched them to D in the csv file used by Trunk Recorder, it started working. So try that. And, also consider adding the defaultMode option.
Thanks for the tips Mike! I switched the Ts to Ds and still had the issue with the issue with incorrect frequency. I added defaultMode option, and still had the incorrect frequency. I changed the center freq lower to cover the incorrect frequency, and at least got it recording some frequencies. However, I ran into this known issue with Phase 2 systems where audio is garbled(not encrypted talkgroups):

I'll do some more testing. It seems like P2 systems are a bit of challenge right now.

@cellphone
Any interest in feeding to Broadcastify Calls in parallel?

Thanks for the invite Lindsay! I am interested. I'll PM or e-mail you with details on my side.
 
Last edited:
Status
Not open for further replies.
Top