TRX-1 Keypad

Status
Not open for further replies.

highmaster2

Member
Premium Subscriber
Joined
Sep 13, 2006
Messages
64
Location
Cropwell, Alabama
On my keypad, every key "snaps" when I press it except the "Period" key (lower left corner). Is that normal, or am I already having a switch headed for failure? It does work, it just doesn't snap. Just wondered how everyone else's worked.

Thanks!
 

NM9X

Member
Premium Subscriber
Joined
Oct 25, 2016
Messages
58
Location
Mt. Zion, IL
On my keypad, every key "snaps" when I press it except the "Period" key (lower left corner). Is that normal, or am I already having a switch headed for failure? It does work, it just doesn't snap. Just wondered how everyone else's worked.

Thanks!
my period snaps like all the other buttons
 

kikito

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
2,539
Location
North Pole, Alaska
Yeah, some keypads have come with minor defects at first that work themselves out later like in my case, almost all the left-most keys didn't work or had a click but after a few days of messing with it, now is good.

Yeah, is not normal and it shouldn't be that way. So if you're concerned, you should return/exchange it or open a ticket with Whistler.


Sent from my iPad using Tapatalk Pro
 

nessnet

Member
Premium Subscriber
Joined
Jan 22, 2007
Messages
222
Location
Kenmore, WA
Just an FYI.....

I had to have Hamstation replace a TRX-1, (one of the perks of buying from Hamstation).
It was because I got a TRX-1 that had a completely bad period key.

It didn't "snap" at all.
In fact, it would mostly stick in a depressed state, causing the TRX-1 to beeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeep.
Basically locking up the device, unless I got something and pulled up on the key, pulling the carbon button off of the contacts.

I even disassembled the unit and confirmed that it wasn't binding on the faceplate, etc.
There was no "snap' even when it was just the silicone keypad and pressing the period.
All other keys worked perfectly.

There definitely have been bad keypads making their way past Whistler's QC.
At least on lower serial no ones.
 

nessnet

Member
Premium Subscriber
Joined
Jan 22, 2007
Messages
222
Location
Kenmore, WA
Yes, that is SOP for most mfgs

But, it was Hamstation..... I keep telling people, the only ones to buy from.

Jeff didn't care - in fact he appreciated my diagnosis.
Plus, it would be damn hard to tell it was ever opened.
Of course, I also know what I am doing and knew just how to do it properly.
You just need to know where those 2 little 2 prong connectors are.
And I recommend using anti-stat measures when doing it.
 
Status
Not open for further replies.
Top