TRX-1: TRX-1 stuck at Whistler logo

digitizing

Member
Joined
Feb 17, 2012
Messages
63
My TRX-1 stuck at whistler logo when powering on.
I can up/downgrade firmware without problem.
When the radio pluged in to USB, I can read/write the microsd.
Is there anyway to repair it myself? I can do solder/desoldering.
I'm outside US, so I think send to whistler for repair is not possible for me.
 

varagold

Newbie
Joined
Dec 6, 2012
Messages
3
Location
Grenoble, France
Hi,

I would check the SDCard first, using an external reader. Maybe the filesystem is corrupted or the SDCard is damaged.


Cheers.
---
Daniel
 

digitizing

Member
Joined
Feb 17, 2012
Messages
63
Yes I have tried several SD card, but the result is same.
The SD card working fine in pro668.
 

Ubbe

Member
Joined
Sep 8, 2006
Messages
4,921
Location
Stockholm, Sweden
The scanner displays "Init File System" before the logo comes up, so the SD Card and its files are ok. After the logo it should start to load your config from the SD card.

Have you tried to just format the card from EZ-Scan and not copy any config to it? It could be something wrong with the config files. Check if that will make it go past the logo screen.

If that works then save your current config to a v-scanner file and then also copy to a second v-scanner file and make that your startup v-scanner file. Edit that config and delete half of all system and see if that will fix it. If not, delete everything. If it solved the problem then copy your config again from the v-scanner file to a new v-scanner file and start deleting one system at the time and check when scanner starts working again. It's probably the last thing you added or edit that are the problem system.

I don't believe there's any hardware problem that needs to be repaired, it's just some configuration problem with the files.

/Ubbe
 

digitizing

Member
Joined
Feb 17, 2012
Messages
63
I just tried to format the SD card without copying any config file (the SD card was blank after formatting),
it gave an error 05-00 (Unable to load CONFIG__.BIN)
Then I manually copy CONFIG__.BIN file to SD card (SD card content CONFIG__.BIN file, without any other folder)
And it stuck at whistler logo. I think the scanner have problem when loading DSP file (version 3.2)
but I'm sure that CONFIG__.BIN file is fine.
The size is 91090 byte and MD5 checksum is 5917941E41561B4ED16A9BA0F2A4F352.
 

Ubbe

Member
Joined
Sep 8, 2006
Messages
4,921
Location
Stockholm, Sweden
It should start to load after the whistler logo, so you could be right that it is some kind of problem with the firmware. You can download the standalone firmware updater from whistlers website and they always have one older version available, so downgrade and start the scanner to inistialize with that version and then upgrade to current version.

/Ubbe
 

gh6406

Member
Premium Subscriber
Joined
Apr 25, 2013
Messages
162
Location
Dalton,Ga
Check all of your EZScan versions. Be sure to perform the PC Application update FIRST. Then do each of the remaining updates one at a time.


EZScan.JPG
 

jdolina

Member
Premium Subscriber
Joined
Jul 4, 2006
Messages
448
Location
Lorain Ohio
Ok don't see you tried this. Unplug all cables, take out batteries hold the power button and count slowly to 30 (seriously 30). Put batteries back in and power on.
 

Wackyracer

Member
Premium Subscriber
Joined
Feb 18, 2016
Messages
1,419
Not all micro SD cards are compatible with whistler scanners, get a 8gb Sandisk CLASS 4 speed card from amazon under $7 shipped with prime. Get this one...Amazon.com: SanDisk 8GB microSD High Capacity (microSDHC) Card - (Class 4) - 8 GB: Computers & Accessories

Then in ezscan use PREPARE card, check everything off so it formats, loads your configuration and the library data, if that does not fix it use the standalone installer to reinstall the CPU firmware, if that still doesn't fix it you will have to send it back to whistler.
 
Top