TwoTone picking up other tones

Status
Not open for further replies.

RacetrackVFD

Member
Joined
Jun 23, 2014
Messages
2
Greetings RR. I successfully got TwoToneDetect running and able to receive tones, but it is picking up other tones as well. I noticed that if an individual set of tones go out (page just an ambulance), it works correctly. But if a set of two tones go out, it picks up those tones as my tones, TwoTones sends out the emails but they are not for the correct tones (note: it does work for my tones).

I attached the tonelog & my tones.cfg.

Any Ideas, thanks everyone.
 

Attachments

DC31

Member
Feed Provider
Joined
Feb 19, 2011
Messages
1,258
Location
Massachusetts
Greetings RR. I successfully got TwoToneDetect running and able to receive tones, but it is picking up other tones as well. I noticed that if an individual set of tones go out (page just an ambulance), it works correctly. But if a set of two tones go out, it picks up those tones as my tones, TwoTones sends out the emails but they are not for the correct tones (note: it does work for my tones).

I attached the tonelog & my tones.cfg.

Any Ideas, thanks everyone.
A couple more things that would help to figure this one out:

1. Can you post a tonelog.txt showing a set of two tones where it is inadvertantly sending emails to you?
The file that you have posted appears to be your tone set being decoded properly.

2. Can you post a copy of your config.cfg file with the email credentials removed?

Your tones do not appear to be standard QuickCall format. Yours appear to be a long Atone followed by a short Btone. Based on the limited information seen here, I would suggest that you use a Btone length of .4 in your Tones.cfg. However, that won't solve the problem that you are reporting. It will just more reliably pick up the Btone.
 

RacetrackVFD

Member
Joined
Jun 23, 2014
Messages
2
DC31,

Thanks for the reply, here is the information you requested.

Additionally I noticed that in our county, alot of the A tones are the same. If you use Notepad ++, go to line 998, you will see where it believes that it picked up our tones (330.5, 457.9), the tone it picked up was 451. I am guessing there might be a tolerance or something to that effect, just a guess on my part.

I also made the adjustment to the Btone as you suggested.

Again any help would be greatly appreciated.
 

Attachments

DC31

Member
Feed Provider
Joined
Feb 19, 2011
Messages
1,258
Location
Massachusetts
DC31,

Thanks for the reply, here is the information you requested.

Additionally I noticed that in our county, alot of the A tones are the same. If you use Notepad ++, go to line 998, you will see where it believes that it picked up our tones (330.5, 457.9), the tone it picked up was 451. I am guessing there might be a tolerance or something to that effect, just a guess on my part.

I also made the adjustment to the Btone as you suggested.

Again any help would be greatly appreciated.

Okay, I got it now. Yours are standard 1 sec/3 sec tone sets. I was looking at them backwards. The problem you are experiencing is because the channel that you are monitoring sends out a brief 451 hz signal after each tone set. TTD decodes that as an acceptable 457.9 tone in your Racetrack tone set. You have your tone tolerance set to 2% making the acceptable range for the 451 tone to be 442-460 (+/- 9 which is 2% of 451)

There are two fixes:

1. Change your tolerance to 1% in your config.cfg file. This might cause other problems since you are decoding low frequency tones. The lower the frequency the narrower the band of acceptable tones becomes. (I would suggest trying #2 first)

2. Adjust your tone lengths in Tones.cfg. Set your Atone to .6 and your Btone to 1.6. (Disregard what i said about tone lengths in the previous post) It appears that the false 451 tone is 1 sec or less in length (each sample in log.txt is 200 ms). Setting it to 1.6 will require that 8 samples are detected before TTD considers it to be a valid tone.

Remember, that after you make either of the above changes, you will need to restart TTD for them to take effect.

Good luck with it.

Jim
 
Status
Not open for further replies.
Top