• To anyone looking to acquire commercial radio programming software:

    Please do not make requests for copies of radio programming software which is sold (or was sold) by the manufacturer for any monetary value. All requests will be deleted and a forum infraction issued. Making a request such as this is attempting to engage in software piracy and this forum cannot be involved or associated with this activity. The same goes for any private transaction via Private Message. Even if you attempt to engage in this activity in PM's we will still enforce the forum rules. Your PM's are not private and the administration has the right to read them if there's a hint to criminal activity.

    If you are having trouble legally obtaining software please state so. We do not want any hurt feelings when your vague post is mistaken for a free request. It is YOUR responsibility to properly word your request.

    To obtain Motorola software see the Sticky in the Motorola forum.

    The various other vendors often permit their dealers to sell the software online (i.e., Kenwood). Please use Google or some other search engine to find a dealer that sells the software. Typically each series or individual radio requires its own software package. Often the Kenwood software is less than $100 so don't be a cheapskate; just purchase it.

    For M/A Com/Harris/GE, etc: there are two software packages that program all current and past radios. One package is for conventional programming and the other for trunked programming. The trunked package is in upwards of $2,500. The conventional package is more reasonable though is still several hundred dollars. The benefit is you do not need multiple versions for each radio (unlike Motorola).

    This is a large and very visible forum. We cannot jeopardize the ability to provide the RadioReference services by allowing this activity to occur. Please respect this.

Weird problem: Wouxun KG-UV8D & CHIRP

Status
Not open for further replies.

Sconnick

Member
Joined
Mar 5, 2014
Messages
82
Hey all,

I have a weird issue with a KG-UV8D and CHIRP programming - or maybe its the OEM software. Here goes...

I have been programming these inexpensive Chinese radios for a few years now. I've learned enough to understand driver issues, cable issues, and all sorts of other stuff. This problem is unique to the UV8D. I downloaded an image of a new UV8D in CHIRP yesterday, and loaded in all the frequencies that I wanted to add. Uploaded back to the radio with no problem. I fired it up and tested a few frequencies - all worked perfectly well - as expected - until I got to a frequency using DCS. No good. Wouldn't break squelch on receive and wouldn't break the squelch on other radios when transmitting.

I opened up the CHIRP file and double checked settings and everything was correct. Out of curiosity (frustration?), I downloaded the image of the radio into the UV8D OEM software and discovered that all of the DCS codes had been inverted. I corrected them in the OEM software and sent them back to the radio. This time, the radio works as advertised. However, now when I try to download the image into CHIRP (my preferred editor), it gives me an error on each of those channels that employ DCS.

Any thoughts before I reach out to CHIRP?

Thanks in advance!

Sean
 

riccom

That scanner geek in the big easy!
Premium Subscriber
Joined
Jul 2, 2004
Messages
1,132
Location
SLIDELL, LA
Check to see in the dcs if it is i or n (inverted or. Normal)

Sent from my LGMS345 using Tapatalk
 

Sconnick

Member
Joined
Mar 5, 2014
Messages
82
That's the problem. None of my DCS codes should be inverted. Every last one is just "normal."

In CHIRP, they're all normal.

When I upload to the radio, they become inverted for some reason. If I open them in the OEM software, they show as - for example - "DI023" instead of "DN023." I can fix them in the OEM software, but then I can't download from the radio back into CHIRP.
 

Sconnick

Member
Joined
Mar 5, 2014
Messages
82
I should add that I've done this countless times with variants of the UV-5R (gone from CHIRP to the OEM VIP software and back) and nothing has ever twisted my DCS codes around.
 

riccom

That scanner geek in the big easy!
Premium Subscriber
Joined
Jul 2, 2004
Messages
1,132
Location
SLIDELL, LA
Have you proggramed the dcs to just xmit and see if it hits a repeater by chance?

Sent from my LGMS345 using Tapatalk
 

Sconnick

Member
Joined
Mar 5, 2014
Messages
82
I don't have any readily accessible DCS repeaters here - all use standard CTCSS. I do have other radios on my desk, though, programmed through CHIRP that function as advertised. That is to say, I can have a pair of UV-5Rs programmed the same way and they talk to each other fine. CHIRP sends "normal" DCS codes to the radio when programming and everything works. However, programming the UV8D the same way, the DCS code becomes inverted and won't open the squelch on xmit or receive.
 

riccom

That scanner geek in the big easy!
Premium Subscriber
Joined
Jul 2, 2004
Messages
1,132
Location
SLIDELL, LA
Sounds like a issue software wise, could be some coding in the software.
Hit the chirp boards they can also help troubleshoot this.
Have you also tried another wouxon radio by chance

Sent from my LGMS345 using Tapatalk
 

Sconnick

Member
Joined
Mar 5, 2014
Messages
82
The only thing I haven't tried is another Wouxun radio, but the fact that it can be fixed with the OEM software and then just not read correctly by CHIRP makes me think software as well... I'll try the CHIRP boards, too. Thanks!
 

riccom

That scanner geek in the big easy!
Premium Subscriber
Joined
Jul 2, 2004
Messages
1,132
Location
SLIDELL, LA
How long ago did you download the software if more then a month try the new daily built

Sent from my LGMS345 using Tapatalk
 

Sconnick

Member
Joined
Mar 5, 2014
Messages
82
Most recent build. I think it was 1/15 or 1/17....

EDIT: 1/15/2017 is the most recent build that I'm using.
 

Sconnick

Member
Joined
Mar 5, 2014
Messages
82
UPDATE: I'm going back and forth with Dan and the folks at CHIRP trying to get to the bottom of this one... I'll post a resolution if and when we find one, in the event that anyone is experiencing the same issue.
 

N0UUS

Newbie
Premium Subscriber
Joined
Jan 4, 2010
Messages
2
Location
Iowa
chirp and KG-UV8D

I have had the same issues. It didn't used ot be an issue with Chirp. But now, if I load to radio, it alters the ctcss area. The Mikor software shows the corruption when you upload to PC using that. Using Mikor's everything programs fine. Would love to use Chirp and the RR files, but then have to go in and modify each channel.
 
Status
Not open for further replies.
Top