BCD536HP: WiFi not holding a connection

Status
Not open for further replies.

AE7Q

Member
Premium Subscriber
Joined
May 2, 2013
Messages
130
Location
Mill Creek, WA
As I understand it, the Android/WiFi application is not yet available, so there's plenty of time to fix the following bug:

The WiFi module makes a connection easily enough, but does not hold it. The WiFi icon remains on the screen, but PINGs to the IP address of the Uniden WiFi adapter stop getting replies after a while. I haven't done any timing tests, but it seems to lose the connection around the time of the DHCP lease expiration. The DHCP server (on Linux) in question is from ISC (Internet Software Consortium) and is considered to be the "reference standard".

Simply power-cycling the BCD536HP causes the connection to be re-established. I now have a timing test running that should pin down the time interval.
 
Last edited:

fxdscon

¯\_(ツ)_/¯
Premium Subscriber
Joined
Jan 15, 2007
Messages
5,190
As I understand it, the Android/WiFi application is not yet available, so there's plenty of time to fix the following bug:

The WiFi module makes a connection easily enough, but does not hold it. The WiFi icon remains on the screen, but PINGs to the IP address of the Uniden WiFi adapter stop getting replies after a while. I haven't done any timing tests, but it seems to lose the connection around the time of the DHCP lease expiration. The DHCP server (on Linux) in question is from ISC (Internet Software Consortium) and is considered to be the "reference standard".

Simply power-cycling the BCD536HP causes the connection to be re-established. I now have a timing test running that should pin down the time interval.
Upman has commented several times that the WiFi module firmware is a large part of the delay, and is being worked on:

http://forums.radioreference.com/uniden-forums/291260-siren-update.html#post2190629

.
 

AE7Q

Member
Premium Subscriber
Joined
May 2, 2013
Messages
130
Location
Mill Creek, WA
Upman has commented several times that the WiFi module firmware is a large part of the delay, and is being worked on:

http://forums.radioreference.com/uniden-forums/291260-siren-update.html#post2190629

.
Thanks! I did a brief search and did not find that info (probably because I did not search for Siren).

I have 40+ years of software development experience, and more than half of that is embedded software development. The fact that a company (not Uniden, but their vendor) would deliver software of that quality (TWICE) is unbelievable.

However, the problem that I observed is not a failure in transferring lots of data, but simply losing the connection. And, I was apparently wrong in associating it with DHCP: I restarted the BCD536HP at 2:30pm, and at 9:00pm (6.5 hours later), the connection is still up. Since my DHCP server is issuing 2 hour leases, that means that five DHCP renewals have successfully occurred, and DHCP renewals are not the problem.
 
Last edited:

JamesO

Member
Joined
Jan 22, 2003
Messages
1,816
Location
McLean, VA
If Uniden would have only tried this simple test 24-36 months ago, they would have known something was up!

Too bad for us now, have to wait a while before we see something working properly.
 
Status
Not open for further replies.
Top