• To anyone looking to acquire commercial radio programming software:

    Please do not make requests for copies of radio programming software which is sold (or was sold) by the manufacturer for any monetary value. All requests will be deleted and a forum infraction issued. Making a request such as this is attempting to engage in software piracy and this forum cannot be involved or associated with this activity. The same goes for any private transaction via Private Message. Even if you attempt to engage in this activity in PM's we will still enforce the forum rules. Your PM's are not private and the administration has the right to read them if there's a hint to criminal activity.

    If you are having trouble legally obtaining software please state so. We do not want any hurt feelings when your vague post is mistaken for a free request. It is YOUR responsibility to properly word your request.

    To obtain Motorola software see the Sticky in the Motorola forum.

    The various other vendors often permit their dealers to sell the software online (i.e., Kenwood). Please use Google or some other search engine to find a dealer that sells the software. Typically each series or individual radio requires its own software package. Often the Kenwood software is less than $100 so don't be a cheapskate; just purchase it.

    For M/A Com/Harris/GE, etc: there are two software packages that program all current and past radios. One package is for conventional programming and the other for trunked programming. The trunked package is in upwards of $2,500. The conventional package is more reasonable though is still several hundred dollars. The benefit is you do not need multiple versions for each radio (unlike Motorola).

    This is a large and very visible forum. We cannot jeopardize the ability to provide the RadioReference services by allowing this activity to occur. Please respect this.

XTS 5000 Non-Working Buttons

Caesar

Member
Joined
Apr 11, 2005
Messages
244
Location
Cayce, SC
I recently got a XTS5000 VHF Model 2 for Ham Radio. The radio looks great, probably rehoused recently. However the [--] 2 dot button in the middle and the UP and Down on the directional pad won't work, doesn't register, & doesn't make a sound. These 3 buttons line up with each other so i'm wondering if this radio was rehoused if maybe they just didn't connect something correctly that I could easily fix instead of having to ship the radio back to the seller. Any info will be appreciated, i checked a lot online but could not find any similar issues on any forums.
 

chrismol1

Member
Premium Subscriber
Joined
Mar 15, 2008
Messages
151
You can check hardware function of the buttons in test mode. Turn on radio and quickly press 3rd side button 5 times. Press Top side button and then press top orange button. This enters button function test mode. Any functional button press will correspond with a change on the display. Its likely it could need to be disassembled and carefully put back. All this is in the manual if you google XTS5000 Basic service manual
 

Caesar

Member
Joined
Apr 11, 2005
Messages
244
Location
Cayce, SC
You can check hardware function of the buttons in test mode. Turn on radio and quickly press 3rd side button 5 times. Press Top side button and then press top orange button. This enters button function test mode. Any functional button press will correspond with a change on the display. Its likely it could need to be disassembled and carefully put back. All this is in the manual if you google XTS5000 Basic service manual
Thank you, that is a new one for me, i just tested that and all buttons worked except those same 3, they did not register at all, no change to the display.
 

Caesar

Member
Joined
Apr 11, 2005
Messages
244
Location
Cayce, SC
I had a similar issue where the PTT didn't work. I found that whoever recased the radio failed to put the circuit board properly into the slots that hold it.
I'm hoping that i am having the same issue. I'm going by the local Moto shop tomorrow morning to have it checked out and will update.
 
Top