RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Computer Aided Monitoring and Programming > Voice/Control Channel Decoding Software

Voice/Control Channel Decoding Software - For discussion of software applications which decode digital voice formats and trunking control channels. Please use the HF Digital Signals forum for anything below 30MHz.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1141 (permalink)  
Old 02-09-2016, 3:33 PM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2014
Posts: 507
Default

Quote:
Originally Posted by jlxsolutions View Post
that won't work my estimate if same network around 4 to 6 before they start mixing up.
That's the reason why i run a separate instance of telive for each channel now days.
and this is for all channels from the same LA?

if so, you can consider this a known bug. currently all calls are tracked by the usage identifier, next version is planned to have different call tracking (the call id will be the key), and this should fix this problem


unfortunately i can test this software on networks with more than 4 frequencies per LA. for networks with less channels the current scheme works well
Reply With Quote
Sponsored links
  #1142 (permalink)  
Old 02-10-2016, 1:47 AM
Member
   
Join Date: May 2013
Posts: 100
Default

actually each frequency has its own LA and CC same network thou
example The low channels i get from my position (under 392)
Code:
TETRA LOW
1: 391.6375 CC08 LA804
2: 391.3875 CC63 LA275 -250
3: 391.3375 CC40 LA3331 -300
4: 391.2625 CC32 LA3406 -375
5: 391.1625 CC33 LA784 -475
6: 391.0875 CC36 LA3409 -550
7: 391.0625 CC27 LA3423 -575
8: 390.9875 CC38 LA342 -650
9: 390.9375 CC35 LA3334 -700
10:390.8875 CC29 LA3354 -750
11:390.8125 CC38 LA331 -825
12:390.7625 CC28 LA3332 -875
Reply With Quote
  #1143 (permalink)  
Old 02-10-2016, 4:25 AM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2014
Posts: 507
Default

Quote:
Originally Posted by jlxsolutions View Post
actually each frequency has its own LA and CC same network thou
example The low channels i get from my position (under 392)
if different LA/CC then you should be using multiple telive instances, not pipe this into one. it may seem to work, but will lead to confustion
Reply With Quote
  #1144 (permalink)  
Old 02-10-2016, 5:00 AM
Member
   
Join Date: May 2013
Posts: 100
Default

Quote:
Originally Posted by sq5bpf View Post
if different LA/CC then you should be using multiple telive instances, not pipe this into one. it may seem to work, but will lead to confustion
That's what i do
takes a while to set up 12 receivers and rxx files and folders but once done works fine

or well 9 ran out on computing power at 10 apparently.
Reply With Quote
  #1145 (permalink)  
Old 02-10-2016, 5:06 PM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2014
Posts: 507
Default

i've added flowgraphs for the funcube dongle and airspy, contributed by Marian OM1EI

unfortunately i have neither the funcube nor the airspy, could anyone test them if they work?
Reply With Quote
Sponsored links
  #1146 (permalink)  
Old 02-12-2016, 3:05 AM
Member
   
Join Date: May 2013
Posts: 100
Default

Aight this might be a dumb question but for some knucklehead reason i cant figure out the filter useage.
all i want to do is have a list of issi's that are if match do not play.
example list
Code:
7917238 
7917255 
7917460 
7917530 
7917709 
7917760 
7918452 
7918523 
7918456 
7917456 
7918464
Reply With Quote
  #1147 (permalink)  
Old 02-12-2016, 5:35 AM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2014
Posts: 507
Default

Quote:
Originally Posted by jlxsolutions View Post
Aight this might be a dumb question but for some knucklehead reason i cant figure out the filter useage.
all i want to do is have a list of issi's that are if match do not play.
example list
Code:
7917238 
7917255 
7917460 
7917530 
7917709 
7917760 
7918452 
7918523 
7918456 
7917456 
7918464
have a look at the docs "How do i use filters?" (page 10 in telive_doc.pdf)

use a negative filter (this means: if something matches this expression, then don't play it), with an expression which matches these SSIs

the easiest version would be this:
Code:
+(7917238|7917255|7917460|7917530|7917709|7917760|7918452|7918523|7918456|7917456|7918464)
but this should also work (and be shorter):
Code:
791+(7238|7255|7460|7530|7709|7760|8452|8523|8456|7456|8464)
there are also some examples in the rxx script comments, and you can search the internet for "ksh extended patterns"

you could probably also use this (untested) with a positive filter (so this expression matches everything except these SSIs):
Code:
!(791+(7238|7255|7460|7530|7709|7760|8452|8523|8456|7456|8464))

Last edited by sq5bpf; 02-12-2016 at 6:26 AM..
Reply With Quote
  #1148 (permalink)  
Old 02-12-2016, 10:15 AM
Member
   
Join Date: Jan 2004
Posts: 170
Default funcube

It is possible to generate a py file from telive_1ch_simple_gr37_FCD.grc . What is the way to remove GUI once the right frequency is discover ?
Reply With Quote
  #1149 (permalink)  
Old 02-12-2016, 10:26 AM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2014
Posts: 507
Default

Quote:
Originally Posted by grosminet View Post
It is possible to generate a py file from telive_1ch_simple_gr37_FCD.grc . What is the way to remove GUI once the right frequency is discover ?
press F5 (or click run -> generate).

the file will be named top_block.py
Reply With Quote
Sponsored links
  #1150 (permalink)  
Old 02-12-2016, 1:36 PM
Member
   
Join Date: Jan 2016
Location: Leidschendam
Posts: 23
Default

For the RPi2 deployment I created a custom python file - without any WX etc.

http://stefan.konink.de/tetra/tetra.py
Reply With Quote
  #1151 (permalink)  
Old 02-13-2016, 6:01 AM
Member
   
Join Date: May 2013
Posts: 100
Default

I been trying to get Telive to run on someones laptop but i keep getting this odd error
Googling did not help so any suggestions on what is going wrong?
Code:
thread[thread-per-block[6]: <block stream_to_vector (4)>]: thread_bind_to_processor failed with error: 22

thread[thread-per-block[7]: <block keep_one_in_n (5)>]: thread_bind_to_processor failed with error: 22

thread[thread-per-block[8]: <block fft_vcc_fftw (6)>]: thread_bind_to_processor failed with error: 22

thread[thread-per-block[9]: <block complex_to_mag_squared (7)>]: thread_bind_to_processor failed with error: 22

thread[thread-per-block[10]: <block single_pole_iir_filter_ff (8)>]: thread_bind_to_processor failed with error: 22

thread[thread-per-block[11]: <block nlog10_ff (9)>]: thread_bind_to_processor failed with error: 22

thread[thread-per-block[12]: <block message_sink (10)>]: thread_bind_to_processor failed with error: 22

thread[thread-per-block[5]: <block copy (11)>]: thread_bind_to_processor failed with error: 22
CPU info
Code:
Model name:            Intel(R) Celeron(R) D CPU 3.46GHz
Stepping:              5
CPU MHz:               3457.976
BogoMIPS:              6915.95
L1d cache:             16K
L2 cache:              512K
Reply With Quote
  #1152 (permalink)  
Old 02-13-2016, 10:36 AM
Member
   
Join Date: Jan 2004
Posts: 170
Default funcube

Quote:
Originally Posted by sq5bpf View Post
i've added flowgraphs for the funcube dongle and airspy, contributed by Marian OM1EI

unfortunately i have neither the funcube nor the airspy, could anyone test them if they work?
I succeed with funcube . I got TETRA signal . 2 questions :

- how to adapt "full spectrum signal" step ? I can't center signal in Channel 1 FFT windows

- where in funcube GRC I can modify sample rate in order to run with funcube pro + . Funcube is 92000 , funcube pro + is 196000 . I tried to change in sample rate variable but it isn't enough
Reply With Quote
  #1153 (permalink)  
Old 02-13-2016, 10:38 AM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2014
Posts: 507
Default

it would probably be better to ask on a gnuradio mailing list (or irc channel).

btw did you try running this on the reference system: debian 8, software installed via install_telive.sh (no special gnuradio install etc)?
Reply With Quote
  #1154 (permalink)  
Old 02-13-2016, 11:42 AM
Member
   
Join Date: Jan 2004
Posts: 170
Default no standard answer

I m not using install.sh . I install through sbrac gnuradio script . I install libosmocore from standard because yours isn't working with other softwares (gr-gsm)

I just install osmo and telive and copy my own files and batches

It is working fine

For funcube I m using qthid 4.0 and funcube pro + qthid 4.1 . For rtl sdr and sdrplay , I'm using

osmo-tetra - Osmocom TETRA PHY/MAC implementation

Now I have trouble with telive 1.6 and 1.7 . As I have enough informations on 1.5 it is OK

The better way to use TETRA decode is with qthid because it is the easiest way to change frequencies . It could be a good idea to be connected with cubicsdr and it's IQ output . I did some tests but I didn't succed
Reply With Quote
  #1155 (permalink)  
Old 02-13-2016, 2:13 PM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2014
Posts: 507
Default

you changed too many things, so you'll have to figure it out yourself (which is ok, because you have everything that is needed to diagnose the problem - the full source code).

a couple of hints to help you:

- the "thread_bind_to_processor failed" is a gnuradio problem, and not a telive/osmo-tetra-sq5bpf problem. see if you can run a simple fm receiver on your gnuradio version (either make one yourself or search for multimode.grc).

- stock libosmocore should be ok. libsomocore-sq5bpf is there just because i wanted to have a stable version.

- you know that you can get incremental versions from github? see here:
https://github.com/sq5bpf/telive/commits/master
https://github.com/sq5bpf/osmo-tetra...commits/master

and then try this in the telive or osmo-tetra-sq5bpf directory :
git checkout XXXXX (where XXXX is the hash that you see on the page)
and compile again.

this way you check each version and see which commit broke your installation. btw tetra-rx and telive still accept the same data as previous versions, so should work for you regardless of what software you use as the receiver.
Reply With Quote
Sponsored links
  #1156 (permalink)  
Old 02-13-2016, 7:31 PM
Member
   
Join Date: May 2013
Posts: 100
Default

Well i found out why the errors (thread_bind_to_processor failed with error: 22)
came there was a 1 in the affinity in telive_1ch_simple_gr37.grc
Code:
<param>
      <key>affinity</key>
      <value>1</value>
    </param>
changed that to a 0 and now it works
Reply With Quote
  #1157 (permalink)  
Old 02-14-2016, 6:48 AM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2014
Posts: 507
Default

Quote:
Originally Posted by jlxsolutions View Post
Well i found out why the errors (thread_bind_to_processor failed with error: 22)
came there was a 1 in the affinity in telive_1ch_simple_gr37.grc
thanks! the fixed version is on github

don't set this to 0, but disable completely. btw this bug will only be present in systems with only 1 core, so this affects only people running this on virtual machines with only one core assigned, 99% other machines have multiple cores and will not be affected

btw i mixed your's and grosminet's posts, sorry
Reply With Quote
  #1158 (permalink)  
Old 02-14-2016, 8:19 PM
Member
   
Join Date: May 2013
Posts: 100
Default

Quote:
Originally Posted by sq5bpf View Post
thanks! the fixed version is on github

don't set this to 0, but disable completely. btw this bug will only be present in systems with only 1 core, so this affects only people running this on virtual machines with only one core assigned, 99% other machines have multiple cores and will not be affected

btw i mixed your's and grosminet's posts, sorry
The "fixed" version does not work on my friends machine the full spectrum click to tune does not display spectrum.(might just be it is working correctly but his machine cant handle it)
Anyways i am going to suggest he get a proper computer to do the decoding. trying to setup things with a 2 to 4 second delay over Teamviewer is not fun LoL
Reply With Quote
  #1159 (permalink)  
Old 02-19-2016, 8:04 AM
   
Join Date: Feb 2016
Posts: 1
Default Not logging or voice

Hi all,

I am using Telive 1.7 but an not getting any logging or any voice traffic at all. Monitoring a network in Norway, and I can see traffic on there (non encrypted).

I have tried on Kali as a VM, and also Ubuntu 15 installed onto a laptop.

I know that I am doing something wrong...but cannot imagine what. I enabled loggin in the RXX script, and even changed the path to \home\(user)\Documents for logging and recording. No directories or logs appear when running telive. FYI I used the telive installation script in both places.

Thanks in advance for your help.
Reply With Quote
  #1160 (permalink)  
Old 02-19-2016, 3:55 PM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2014
Posts: 507
Default

Quote:
Originally Posted by dannyllama0564 View Post
I am using Telive 1.7 but an not getting any logging or any voice traffic at all. Monitoring a network in Norway, and I can see traffic on there (non encrypted).
if you see traffic in the telive lower-left window, then if you enable logging (press l , so that the top row displays log:1), you should get a file /tetra/log/telive.log (or somewhere else if you reconfigured it) with the same content. if you don't then maybe it's a permissions issue (if you used install_telive.sh, then it prevents the script from running as root, so it should be ok, but if you used some other install method then check permissions).

for voice traffic first check if you can play the testfile.acelp file correctly. does the telive screen show PLAY next to the usage identifiers?
Reply With Quote
Reply

Tags
tetra decode

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 3:49 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2015 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions