• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

problem starting darkice

Status
Not open for further replies.

gorditazz

Newbie
Joined
Feb 1, 2010
Messages
1
Hi I'm getting the following error when starting darkice on my ubuntu machine

Using config file: /etc/darkice.cfg
01-Feb-2010 22:11:26 Using JACK audio server as input device.
01-Feb-2010 22:11:26 encoding
01-Feb-2010 22:11:26 scheduler high priority 99
01-Feb-2010 22:11:26 Could not set POSIX real-time scheduling, this may cause recording skips.
Try to run darkice as the super-user.
01-Feb-2010 22:11:26 Registering as JACK client darkice-2402
01-Feb-2010 22:11:26 JackDspSource :: do_auto_connect
01-Feb-2010 22:11:26 Connecting system:capture_1 to darkice-2402:mono
01-Feb-2010 22:11:26 0 bytes transfered to the encoders
01-Feb-2010 22:11:26 encoding ends

I have tried to run it as sudo but if I do then it cannot see qjackctrl as that's run as normal user:

01-Feb-2010 22:11:55 Using POSIX real-time scheduling, priority 98
DarkIce: JackDspSource.cpp:210: JACK server not running? [0]

That's because jack isnt running as root. I need to run it as root as i need ardour to talk to jack too. My idea is: systemInput - recordArdour - outArdour - darkiceStream. all controlled by jackctrl.

If I run qjackctrl as root and darkice as root I get this, just for a test to see if the problem is the user:

Using JACK audio server as input device.
Using POSIX real-time scheduling, priority 98
Registering as JACK client darkice-14039
DarkIce: LameLibEncoder.cpp:75: lame lib opening underlying sink error [0]

I installed darkice with lame and jack support,. lame is installed and I think i have all the libraries needed (suggestions welcome). Jackd is running and i control it with qjackctrl. Password and mount point for the icecast server are fine. Seen in this forum the problem might be the lame not able to talk to jack if it isnt root.

How can i make darkice to be able to talk to jack if jackctrl isnt run as root?? what am doing wrong?

sending my darkice.cfg...

thanks in advance
gorditazz
 
Status
Not open for further replies.
Top