• To anyone looking to acquire commercial radio programming software:

    Please do not make requests for copies of radio programming software which is sold (or was sold) by the manufacturer for any monetary value. All requests will be deleted and a forum infraction issued. Making a request such as this is attempting to engage in software piracy and this forum cannot be involved or associated with this activity. The same goes for any private transaction via Private Message. Even if you attempt to engage in this activity in PM's we will still enforce the forum rules. Your PM's are not private and the administration has the right to read them if there's a hint to criminal activity.

    If you are having trouble legally obtaining software please state so. We do not want any hurt feelings when your vague post is mistaken for a free request. It is YOUR responsibility to properly word your request.

    To obtain Motorola software see the Sticky in the Motorola forum.

    The various other vendors often permit their dealers to sell the software online (i.e., Kenwood). Please use Google or some other search engine to find a dealer that sells the software. Typically each series or individual radio requires its own software package. Often the Kenwood software is less than $100 so don't be a cheapskate; just purchase it.

    For M/A Com/Harris/GE, etc: there are two software packages that program all current and past radios. One package is for conventional programming and the other for trunked programming. The trunked package is in upwards of $2,500. The conventional package is more reasonable though is still several hundred dollars. The benefit is you do not need multiple versions for each radio (unlike Motorola).

    This is a large and very visible forum. We cannot jeopardize the ability to provide the RadioReference services by allowing this activity to occur. Please respect this.

G1 charging problen

Status
Not open for further replies.

cabelas16

Newbie
Joined
Jan 16, 2017
Messages
1
So i ran my g1 completely dead, to the point ut shut off, i put it on the cradle charger, and it wouldnt charge. Blinked red on the dock. Is this a known issue with these pagers? The fix?
 

evfd1625

Member
Joined
Apr 29, 2007
Messages
368
Location
Indiana
Replace the batteries. Or take them out and try charging them in another charger and see if that fixes it.

Sent from my SAMSUNG-SM-G891A using Tapatalk
 

10-75

Member
Premium Subscriber
Joined
Jan 20, 2004
Messages
76
Location
New York
First I would check and make sure your contacts on the bottom of the pager and charger are both clean.... I have had the same issue and that was the cause most of the time.... If that doesn't help, I would replace your batteries.... I have never had so many batteries fail in any device I've ever owned. The batteries in my G1 over a short period of time all developed a high internal resistance and ended up not holding a charge or refusing to charge. I have to say the G1 is a great pager marred by poor battery design / capacity.... Good luck...
 
Status
Not open for further replies.
Top