Heap Error

Status
Not open for further replies.

WA6IJD

Member
Premium Subscriber
Joined
Nov 10, 2003
Messages
41
Location
Buckeye, AZ
First error with my PSR-500. Worked fine the night before, was listening to the TG's working the President's visit. Next morning, it turned on OK. But when I pressed any button except the light button, it would display "Heap Error" with some numbers in the line below that. Did some testing by loading another folder via software. That folder worked fine. So to fix the problem, I created a new template and copied over all the data. Has worked fine since. Just something in the data for the folder.
 

Stick0413

Member
Premium Subscriber
Joined
May 16, 2005
Messages
1,118
Location
Hopewell, VA
Yeah its a common message. I have had it once (when I first got my 500) and Don Starr mentioned something about it once I believe. The wiki article that Mike just linked should give you the answer.
 

WA6IJD

Member
Premium Subscriber
Joined
Nov 10, 2003
Messages
41
Location
Buckeye, AZ
Since my first post, and read the post by KA3JJZ, I've emailed the factory to see if there is anything new regarding a "Heap Error". Factory reports nothing new there, basically said the same thing that's here on RR. With the addition of they did recommend checking the "Unassigned" box to check for possibles. However, by my simply copying and pasting into a new template, then uploading to the radio fixed the issue (now 2 days without seeing the error) does go against what they are saying... But it has worked none the less. So there is something underlying in the heap error issue. Probably never know.

Robert
 

jerk

Active Member
Joined
Sep 5, 2003
Messages
2,449
Location
jerkville
Since my first post, and read the post by KA3JJZ, I've emailed the factory to see if there is anything new regarding a "Heap Error". Factory reports nothing new there, basically said the same thing that's here on RR. With the addition of they did recommend checking the "Unassigned" box to check for possibles. However, by my simply copying and pasting into a new template, then uploading to the radio fixed the issue (now 2 days without seeing the error) does go against what they are saying... But it has worked none the less. So there is something underlying in the heap error issue. Probably never know.

Robert
What software package are you using?
I think the wisdom found here and from the factory is correct...
Most programming software has an option to delete or not allow duplicates, so by default of the software, you "solved" the problem, [by pasting into a new template].
 
Status
Not open for further replies.
Top