Help Installing/Compiling DSD on LINUX MINT

Status
Not open for further replies.

wiredwrx

Member
Joined
Dec 20, 2004
Messages
43
I have been running DSD on a windows machine for a while. I recently installed Linux Mint (Release 13 MAYA) on an older laptop.

I was searching, and found this https://github.com/szechyjs/dsd

I followed the instructions as follows, and ran into several problems and errors.


TYPED "sudo apt-get update"

RESPONSE
It ran through a bunch of stuff, and then gave the following
Err http://packages.medibuntu.org precise/free i386 Packages
Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Err http://packages.medibuntu.org precise/non-free i386 Packages
Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Err http://packages.medibuntu.org precise/free Translation-en_US
Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Err http://packages.medibuntu.org precise/free Translation-en
Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Err http://packages.medibuntu.org precise/non-free Translation-en_US
Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Err http://packages.medibuntu.org precise/non-free Translation-en
Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)
Fetched 1,844 kB in 2min 26s (12.6 kB/s)
W: Failed to fetch http://packages.medibuntu.org/dists/precise/Release.gpg Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://packages.medibuntu.org/dists/precise/free/binary-i386/Packages Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://packages.medibuntu.org/dists/precise/non-free/binary-i386/Packages Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://packages.medibuntu.org/dists/precise/free/i18n/Translation-en_US Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://packages.medibuntu.org/dists/precise/free/i18n/Translation-en Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://packages.medibuntu.org/dists/precise/non-free/i18n/Translation-en_US Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://packages.medibuntu.org/dists/precise/non-free/i18n/Translation-en Something wicked happened resolving 'packages.medibuntu.org:http' (-5 - No address associated with hostname)

E: Some index files failed to download. They have been ignored, or old ones used instead

TYPED "sudo apt-get install git make cmake"

RESPONSE
Reading package lists... Done
Building dependency tree
Reading state information... Done
git is already the newest version.
cmake is already the newest version.
make is already the newest version.
The following packages were automatically installed and are no longer required:
cdparanoia libk3b6 libflac++6 kde-l10n-engb libkcddb4 k3b-data libgtkhex-3-0
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 97 not upgraded.

TYPED "git clone git://github.com/szechyjs/dsd.git"

RESPONSE
Cloning into 'dsd'...
remote: Reusing existing pack: 331, done.
remote: Total 331 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (331/331), 557.51 KiB | 442 KiB/s, done.
Resolving deltas: 100% (135/135), done.

TYPED "cd dsd"
TYPED "mkdir build"
TYPED "cd build"

And then, this is where I can not get past,

TYPED "cmake .."

RESPONSE
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at cmake/FindLibSndFile.cmake:18 (MESSAGE):
Could not find sndfile
Call Stack (most recent call first):
CMakeLists.txt:9 (find_package)


-- Configuring incomplete, errors occurred!

Can anyone help out please.
 

jazzbassNick

Member
Joined
Jul 3, 2012
Messages
181
Location
San Gabriel CA
Replying from my phone, so I don't have the particulars handy, but in the readme, I seem to recall it lists 3 dependencies. You need to install those first before trying to compile dsd. Maybe someone will chime in with specifics.
 

wiredwrx

Member
Joined
Dec 20, 2004
Messages
43
Thanks for the help. I will check the readme on the git. Am I typing gthe cmake command correctly, with just "cmake .."??
 

wiredwrx

Member
Joined
Dec 20, 2004
Messages
43
OK, was able to install mbelib and cmake. Then using Ubuntu software manager, installed libsndfile1 (could not find anything labeled sndfile) and then re followed the dsd install procedure. At cmake command, got the following

CMake Error at cmake/FindLibSndFile.cmake:18 (MESSAGE):
Could not find sndfile
Call Stack (most recent call first):
CMakeLists.txt:9 (find_package)

So, it can't find the sndfile. Can anyone give directions. I have googled, and not been able to find anything specific about installing the proper sndfile.
 
Status
Not open for further replies.
Top