OP25 Radioreference Metadata/Alpha Tags issue.

telvana

Member
Feed Provider
Joined
Nov 19, 2014
Messages
36
I am confused in a way about how the meta.json file works. What data needs to go into the meta.json file? If someone could direct me to a decent tutorial or help me figure it out I'd be greatly appreciative. The stream is working great, but the alpha tags refuse to work, even though they work locally. Once I send the data off to radioreference I am no longer receiving metadata/alpha tags.

# ICECAST STREAMING
# Uncomment to enable output to an icecast server
# Change the "host", "password", and "mount" strings appropriately first!
# For metadata to work properly, the host address given here MUST MATCH the address in op25's meta.json file
#
output.icecast(%mp3(bitrate=16, samplerate=22050, stereo=false), description="Lake County Public Safety", genre="Public Safety", url="", fallible=false, icy_metadata="false", host="audio1.broadcastify.com", port=80, mount="XXXXXXXXXX", password="XXXXXXX", mean(input))

{
"icecastPass": "XXXXXXXXXXXX",
"icecastMountpoint": "XXXXXXXXXX",
"icecastServerAddress": "audio1.broadcastify.com:80",
"delay": "0.0", "icecastMountExt": ".m3u",
"meta_format_idle": "[idle]",
"meta_format_tgid": "[%TGID%]",
"meta_format_tag": "[%TGID%] %TAG%"
}

01/10/21 16:20:02.119682 meta_server::send_metadata(): metadata update error: 400

I remember reading something about the way the tags work is that it's scraping the tag data from the icecast website, and that data no longer shows up when streaming to radioreference. I am sure I'm missing something simple, I just can't seem to figure out what it is.

Thanks in advance.
 
Last edited:

a417

!#
Joined
Mar 14, 2004
Messages
2,104
Can you post what meta.json you have?

I am confused by your host not being localhost. If you are hosting the feed from op25, it provides the metadata to be scraped and sent to broadcastify (if my perusal of the online instructions is correct). You are hosting op25, you are streaming it...but you are telling it that the host is audio1.broadcastify.com @ port 80 and not your localhost..

If that is how it is supposed to be to work, then I apologize for my incorrect assumptions
 

telvana

Member
Feed Provider
Joined
Nov 19, 2014
Messages
36
{
"icecastPass": "XXXXXXXXXXXX",
"icecastMountpoint": "XXXXXXXXXX",
"icecastServerAddress": "audio1.broadcastify.com:80",
"delay": "0.0", "icecastMountExt": ".m3u",
"meta_format_idle": "[idle]",
"meta_format_tgid": "[%TGID%]",
"meta_format_tag": "[%TGID%] %TAG%"
}

Pertinent stream information for radioreference is X'd out, for some reason I am thinking that I need to use two output.icecast fields in op25.liq, but I am completely confused as to how this is all supposed to work. From the documents it seems to be setup for local streaming, and not streaming to radioreference, but again I could very well be wrong and just overthinking this.
 

telvana

Member
Feed Provider
Joined
Nov 19, 2014
Messages
36
Strange, according to this post I've configured it correctly. At least, I think so.

 

telvana

Member
Feed Provider
Joined
Nov 19, 2014
Messages
36
That appears to be the issue. Oddly, VLC isn't showing them, but scanner radio does. Sorry for the post, apparently I've never bothered to pay attention to alpha tags on broadcastify until now ... so I never even noticed that they didn't show up on all players. :)
 

Attachments

boatbod

Member
Joined
Mar 3, 2007
Messages
2,725
Location
Talbot Co, MD
That appears to be the issue. Oddly, VLC isn't showing them, but scanner radio does. Sorry for the post, apparently I've never bothered to pay attention to alpha tags on broadcastify until now ... so I never even noticed that they didn't show up on all players. :)
I prefer scanner radio because it reconnects automatically if there is any interruption to the stream.
 
Top