SDR Sharp question

Status
Not open for further replies.

baustm

Member
Premium Subscriber
Joined
Feb 9, 2017
Messages
12
Yeah, this sounds a whole lot like a hardware issue with your computer and less to do with DSD or your radio. What model of Toshiba do you have?
 

moonbounce

Member
Joined
Nov 5, 2002
Messages
1,249
If you are using a tapped scanner with the signal being sent to your computer with only a mic in you need a pigtail adapter. One side of the pigtail adapter will be speaker and the other will be mic.I have the same setup on my laptop and it works perfectly.

Also you should be using line in with a tapped scanner not cable output. And you shouldn't be using FMP.
 

jrl44430

Member
Joined
Nov 2, 2002
Messages
124
Where did you get the pigtail adapter?

I went into control panel and under mic properties and it said location 0 (internal high def audio bus). Does that mean location 0 in DSD?

My Toshiba is the Satellite P205-S6337.
 

moonbounce

Member
Joined
Nov 5, 2002
Messages
1,249
Where did you get the pigtail adapter?

I went into control panel and under mic properties and it said location 0 (internal high def audio bus). Does that mean location 0 in DSD?

My Toshiba is the Satellite P205-S6337.
I got my pigtail from a local computer store, shouldn't be hard to find, I got mine for under $10. The end that plugs into the speaker port will have 4 sections instead of the usual 3. Until you get that pigtail I would think that you can't go any further to decode digital signals using a tapped scanner and DSD.

You could go the SDRSharp route and use VB cable to route the signal to DSD.

MB
 

jrl44430

Member
Joined
Nov 2, 2002
Messages
124
I am a little confused by the pigtail. My laptop has a mic jack and a headphone jack. Do I still need the pigtail?
 

moonbounce

Member
Joined
Nov 5, 2002
Messages
1,249
I am a little confused by the pigtail. My laptop has a mic jack and a headphone jack. Do I still need the pigtail?
In your third post you said your computer only has a mic jack, that is why I said you need a pigtail.















"
 

moonbounce

Member
Joined
Nov 5, 2002
Messages
1,249
I am not sure which one you have but if you have a mike in and headphones in you won't need a pigtail. If there is only one port like my computer it is probably a dual port for headphones and mic in, in which case you will need a pigtail for the mic in and line in.
 

jrl44430

Member
Joined
Nov 2, 2002
Messages
124
Yes I have a mic in and a headphone out.

Control panel says the location for the mic is 0. Does that mean DSD should have -I0? Did not think DSD liked that.
 

moonbounce

Member
Joined
Nov 5, 2002
Messages
1,249
Yes I have a mic in and a headphone out.

Control panel says the location for the mic is 0. Does that mean DSD should have -I0? Did not think DSD liked that.
So If you are using a tapped scanner to decode a digital signal your only concern should DSDPlus.exe, and in the Control panel/ sound/ you should only be dealing with Line in and it should have a value around 3.
 

jrl44430

Member
Joined
Nov 2, 2002
Messages
124
DSD says input device mic is initialized with -i1. The problem is the mic input passes the audio right to the speakers with a flat line. The built in mic picks up the sound from the speakers and changes the amplitude of waveform. There must be something with the sound card.
 

morfis

Member
Joined
Jan 24, 2004
Messages
896
Why are you using the mike as the input?

Looking at your screenshot of your 'desktop' you should be using input 2 - the line in (input 1 is your INTERNAL microphone) as the input for dsd.
 

jrl44430

Member
Joined
Nov 2, 2002
Messages
124
Input 2 is the virtual audio cable. Is the what I want for tapped audio from a radio? This laptop only has a mic jack.

I will order the sound card.

It seems like the audio from the tapped radio goes into the mic jack and right to the computer speakers bypassing DSD,

DSD says mono decoding initiated but nothing happens. All I hear is unsquelched audio and DMR digital data.
 

jrl44430

Member
Joined
Nov 2, 2002
Messages
124
Input 2 is the virtual audio cable. Is the what I want for tapped audio from a radio? This laptop only has a mic jack.

I will order the sound card.

It seems like the audio from the tapped radio goes into the mic jack and right to the computer speakers bypassing DSD,

DSD says mono decoding initiated but nothing happens. All I hear is unsquelched audio and DMR digital data.
 

morfis

Member
Joined
Jan 24, 2004
Messages
896
Input 2 is the virtual audio cable. Is the what I want for tapped audio from a radio? This laptop only has a mic jack.

I will order the sound card.

It seems like the audio from the tapped radio goes into the mic jack and right to the computer speakers bypassing DSD,

DSD says mono decoding initiated but nothing happens. All I hear is unsquelched audio and DMR digital data.
Apologies, wasn't clear enough on my phone screen.

No, you want 'line in'. You may need to enable it from the windows sound settings before it can be accessed . I had to do that on my ancient sony and toshiba laptops.

By default disabled devices weren't shown in the 'recording devices' list.
You can try right clicking in the empty white space below the devices that are listed and you'll get a pop-up where you can select to show disabled devices. Check both boxes and the external mike/line in should show. Use Properties to enable it.

Newer toshibas have a function to allow the laptop to be used as an amp with it's speakers even when the OS isn't running (for use with mp3 players and the like) - mine doesn't have this so I'm not sure if you'd have to use the toshiba utilities to turn that function off.
 

jrl44430

Member
Joined
Nov 2, 2002
Messages
124
You were exactly right on going into control panel and setting up the mic input. I am now decoding weak audio. How do I set it so I don't hear unsquelched audio all the time and increase the decoded audio level?.
 

jrl44430

Member
Joined
Nov 2, 2002
Messages
124
Thanks to everyone who help me. I have single channel decoding now. Next challenge is for trunking. Thanks again.
 
Status
Not open for further replies.
Top