Trouble with OP25...

Status
Not open for further replies.

scaseyjordan

Member
Joined
Aug 9, 2006
Messages
38
Location
Spokane, WA
I am trying to run scope.py on an Ubuntu machine (16.04.2 32-bit) and I keep receiving this traceback. Can anybody help me understand what it is not happy about? I know that the command instantiation is not perfect, but it doesn't matter what I type in the command line, it shows this error traceback. Thanks.

Casey

Code:
radio@ubuntu-pc:~/op25/op25/gr-op25_repeater/apps$ ./scope.py --args 'airspy' -g 10 -f 853.5375e6 -S 10000000 -T trunk.tsv
linux; GNU C++ version 5.3.1 20151219; Boost_105800; UHD_003.009.002-0-unknown

gr-osmosdr 0.1.4 (0.1.4) gnuradio 3.7.9
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy redpitaya 
Using AirSpy NOS v1.0.0-rc10-0-g946184a 2016-09-19, samplerates: 2.5M 10M 
gain: name: LNA range: start 0 stop 15 step 1
gain: name: MIX range: start 0 stop 15 step 1
gain: name: IF range: start 0 stop 15 step 1
supported sample rates 2500000-10000000 step 7500000
Using Volk machine: sse4_2_32_orc
Traceback (most recent call last):
  File "./scope.py", line 2759, in <module>
    app = stdgui2.stdapp(p25_rx_block, "APCO P25 Receiver", 3)
  File "/usr/lib/python2.7/dist-packages/gnuradio/wxgui/stdgui2.py", line 46, in __init__
    wx.App.__init__ (self, redirect=False)
  File "/usr/lib/python2.7/dist-packages/wx-3.0-gtk2/wx/_core.py", line 8628, in __init__
    self._BootstrapApp()
  File "/usr/lib/python2.7/dist-packages/wx-3.0-gtk2/wx/_core.py", line 8196, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/gnuradio/wxgui/stdgui2.py", line 49, in OnInit
    frame = stdframe (self.top_block_maker, self.title, self._nstatus)
  File "/usr/lib/python2.7/dist-packages/gnuradio/wxgui/stdgui2.py", line 76, in __init__
    self.panel = stdpanel (self, self, top_block_maker)
  File "/usr/lib/python2.7/dist-packages/gnuradio/wxgui/stdgui2.py", line 98, in __init__
    self.top_block = top_block_maker (frame, self, vbox, sys.argv)
  File "./scope.py", line 213, in __init__
    self.__init_gui(frame, panel, vbox)
  File "./scope.py", line 550, in __init_gui
    self.data_scope = datascope_sink_f(self.notebook, samples_per_symbol = 10, num_plots = 100)
  File "./scope.py", line 1479, in __init__
    v_scale, t_scale, None, title), parent, samples_per_symbol=samples_per_symbol, num_plots=num_plots)
  File "./scope.py", line 1601, in __init__
    self.graph = datascope_graph_window (info, self, -1, samples_per_symbol=samples_per_symbol, num_plots=num_plots)
  File "./scope.py", line 1633, in __init__
    self.SetEnableGrid (False)
  File "/usr/lib/python2.7/dist-packages/gnuradio/wxgui/plot.py", line 650, in SetEnableGrid
    if value not in [True,False]:
wx._core.PyAssertionError: C++ assertion "m_window" failed at ../src/gtk/dcclient.cpp(2043) in DoGetSize(): GetSize() doesn't work without window
 

boatbod

Member
Joined
Mar 3, 2007
Messages
2,403
Location
Talbot Co, MD
OP25 generally doesn't run on 16.04. One or two people have modded it to work, but it's non-trivial effort and requires installation of older wx libraries etc. By far the easiest thing to do is run ubuntu 14.04 and installation will be a snap.
 
Status
Not open for further replies.
Top