DSDplus/ FMPP with SDRPlay API V3.07

matty100_000

Newbie
Premium Subscriber
Joined
Nov 20, 2013
Messages
4
Location
LOS ALTOS, CA
Hi,
I am new to DSDplus/FMPP fastlane. I have a RSPDuo and just installed the latest SDRuno V1.41 that installed SDRplay API ver 3.07. When I try to run FMPP (after updating my SN in the config file first line) I get an error that MFPP is expecting SDRplay API V3.06 and then I get an error after clicking OK that can't open SDRplay device #1 with SN xxxx .... its not present or already in use ....


I tired looking on SDRplay for a way to downgrade SDRUno to version 1.33 (last version before updating the API version to 3.07) to downgrade the API to 3.06 but couldn't find the older versions ....

1. Is the newer API version the cause of my issue
2. Does anybody know how I can downgrade to V3.06 so I can first verify this is the issue and not something else
3. When will MFPP support V3.07?

Thanks
Matty AG6XS
 

nrarend

Newbie
Premium Subscriber
Joined
Aug 1, 2020
Messages
4
The newer API is most likely the cause of your issue. FMPP won't run for me with 3.07 installed. This is inconvenient because I sometimes use other software to decode digital signals that now only support version 3.07. But I use DSDplus the most, so I'm waiting for DSDplus to catch up before I upgrade the API.

You can get 3.06 back by installing SDRuno 1.33 as it will automatically revert back to the 3.06 API. Unfortunately, I cannot find 1.33 anywhere on the SDRplay site either. It seems since 1.40.1 was released, they no longer give the option to download 1.33. Bad move on their part. If they give the option to download older versions, it certainly isn't easy to find. Maybe contact them and request it.
 

BM82557

Member
Joined
Aug 28, 2006
Messages
3,155
Location
Berkeley Co WV
3.06 API installer

 
Top