• To anyone looking to acquire commercial radio programming software:

    Please do not make requests for copies of radio programming software which is sold (or was sold) by the manufacturer for any monetary value. All requests will be deleted and a forum infraction issued. Making a request such as this is attempting to engage in software piracy and this forum cannot be involved or associated with this activity. The same goes for any private transaction via Private Message. Even if you attempt to engage in this activity in PM's we will still enforce the forum rules. Your PM's are not private and the administration has the right to read them if there's a hint to criminal activity.

    If you are having trouble legally obtaining software please state so. We do not want any hurt feelings when your vague post is mistaken for a free request. It is YOUR responsibility to properly word your request.

    To obtain Motorola software see the Sticky in the Motorola forum.

    The various other vendors often permit their dealers to sell the software online (i.e., Kenwood). Please use Google or some other search engine to find a dealer that sells the software. Typically each series or individual radio requires its own software package. Often the Kenwood software is less than $100 so don't be a cheapskate; just purchase it.

    For M/A Com/Harris/GE, etc: there are two software packages that program all current and past radios. One package is for conventional programming and the other for trunked programming. The trunked package is in upwards of $2,500. The conventional package is more reasonable though is still several hundred dollars. The benefit is you do not need multiple versions for each radio (unlike Motorola).

    This is a large and very visible forum. We cannot jeopardize the ability to provide the RadioReference services by allowing this activity to occur. Please respect this.

impress charger help

Status
Not open for further replies.

nick223

Member
Feed Provider
Joined
Jan 10, 2009
Messages
1,100
Location
Ottawa Illinois
i have impress 6 gang charger WPLN4198A one of the banks doesnt seem to work the LCD screen just reads no battery when the battery is in the bank. I have a brand new battery out of the box that i used in every bank the rest work but for some reason one doesnt. Any ideas what to check or the fix?

Thanks
 

nick223

Member
Feed Provider
Joined
Jan 10, 2009
Messages
1,100
Location
Ottawa Illinois
So i pulled the housing off on every board for the banks once the battery is inserted there is a steady green light thats on on the board. But on the bank that is not working it shows up a flashing red light. any ideas?
 

nick223

Member
Feed Provider
Joined
Jan 10, 2009
Messages
1,100
Location
Ottawa Illinois
Volt meter show good power to board and to contacts in the pocket. It must be not making good contact in the pocket? Anyone have the answer ?
 

W2NJS

Member
Joined
Mar 27, 2006
Messages
1,938
Location
Washington DC
Nick,

The LCD display modules are pluggable and removable. Try swapping the LCD in the "bad" slot with the LCD from another slot. That'll tell you if the trouble is in the LCD display or the individual charger module.

You also should be aware of what the lights mean:
Yellow = Reconditioning the battery, followed by...
Red = Charging the battery
Green = Fully charged.
More about this can probably be found on the underside of the charger itself.

Regards.

Tom, W2NJS
 

nick223

Member
Feed Provider
Joined
Jan 10, 2009
Messages
1,100
Location
Ottawa Illinois
i think it has something to do with the contacts

i put a non impress battery in the pocket and the charger light stays green and read on the lcd screen "non impress battery" could a firmware update help i know it needs 3.4 and the pockets need 1.7 right now its 3.30 and 1.6
 
Status
Not open for further replies.
Top