Radio Shack 20-047 Driver

Status
Not open for further replies.

ermin

Member
Joined
Dec 21, 2007
Messages
358
Location
Jacksonville Florida
Hello All

So I have been using this cable for over 10 years and also with Windows 10 with zero problems. After the Windows 10 Creators update the cable will not work and I still have the original driver CD but cannot get 10 to work with it.

Any suggestions or where I can get a driver for it that works with windows 10?

Thank you

Ermin
 

DJ11DLN

Member
Premium Subscriber
Joined
Mar 23, 2013
Messages
2,117
Location
Mudhole, IN
Do a Google search on "how to disable driver enforcement for Windows 10." The driver is fine, it's Windows that is causing the problem here. Once you disable driver enforcement, you will be able to load the driver from the CD and it should work.

Be aware that there have been reports of these drivers being disabled by Windows during a Windows Update. In other words, just because you managed to get it to work this time doesn't mean that it will work next month until you go through the whole driver enforcement disable rigmarole all over again. Just something to make our hobby a little more "challenging.":mad:
 

ermin

Member
Joined
Dec 21, 2007
Messages
358
Location
Jacksonville Florida
Do a Google search on "how to disable driver enforcement for Windows 10." The driver is fine, it's Windows that is causing the problem here. Once you disable driver enforcement, you will be able to load the driver from the CD and it should work.

Be aware that there have been reports of these drivers being disabled by Windows during a Windows Update. In other words, just because you managed to get it to work this time doesn't mean that it will work next month until you go through the whole driver enforcement disable rigmarole all over again. Just something to make our hobby a little more "challenging.":mad:

Tried several times and did not work. Windows says that it cannot find a driver for the device on the cd. This is the first time I've ever had a problem with this. Since it occured just after the windows 10 major update that has to be the cause. Anyone with another suggestions? I really appreciate the help.

73

Ermin
 

ermin

Member
Joined
Dec 21, 2007
Messages
358
Location
Jacksonville Florida
Tried several times and did not work. Windows says that it cannot find a driver for the device on the cd. This is the first time I've ever had a problem with this. Since it occured just after the windows 10 major update that has to be the cause. Anyone with another suggestions? I really appreciate the help.

73

Ermin
New update. Now I tried my RT Systems cable for my Icom ham radio and it has the same problem.

AND my cable for my Baofeng which worked perfectly before the big update does not work either.
 

DJ11DLN

Member
Premium Subscriber
Joined
Mar 23, 2013
Messages
2,117
Location
Mudhole, IN
+1. Keep trying, this is the root of your problems. Windows now has (well, has had for awhile) this wonderful "papa knows best" function built into it, to keep you from installing something potentially hazardous. Unfortunately, MS went about 3 steps too far with it.

Of the things stolen in my little break-in episode last fall, I'm now pretty sure that my good old Windows 7 laptop is what I miss the most.:mad:
 

ermin

Member
Joined
Dec 21, 2007
Messages
358
Location
Jacksonville Florida
+1. Keep trying, this is the root of your problems. Windows now has (well, has had for awhile) this wonderful "papa knows best" function built into it, to keep you from installing something potentially hazardous. Unfortunately, MS went about 3 steps too far with it.

Of the things stolen in my little break-in episode last fall, I'm now pretty sure that my good old Windows 7 laptop is what I miss the most.:mad:
Actually I wouldn't mind going back to windows 3.o!

Last reply.

After a wonderful tech support session with Shaun of RT Systems Tech Support we determined that it is a major Windows PROBLEM!!!!!!

Right now when I plug ANY radio programming cable in none work because Windows 10 is putting them in Other Devices so even when you get the driver installed Windows 10 does not assign it a com port there in the Other Devices section. The cable needs to be in a different section..
The driver is being installed, There is just no com port being assigned to the cable.
Thank you to everyone helping and I'll get back when it is fixed.

73

Ermin
 

ttprescott

Newbie
Joined
May 23, 2008
Messages
4
Location
Massachusetts
I have been troubleshooting my Radio Shack Cable 20-047 on a Windows 10 64 bit machine for several hours to no avail. I've tried to disable the driver signature enforcement and have downloaded the ftdchip.com driver link etc.
How do I troubleshoot this further? I'm frustrated and would like to reprogram existing radios. Any further help would be appreciated.
 

N9JIG

Sheriff
Moderator
Joined
Dec 14, 2001
Messages
4,451
Location
Far NW Valley
I just plugged my 20-047 into the computer and Windows 10 Creator (v1703) found the driver automatically and assigned it a Comm Port, no installation needed.

When I originally updated to Creator my RadarBox wouldn't work due to a driver issue but after the weekly updates were installed it worked again.

Try checking for more updates, see if it helps.
 

ttprescott

Newbie
Joined
May 23, 2008
Messages
4
Location
Massachusetts
Still No Luck

Is there a way to test the cable assembly to ensure it's not broken? Can't get the cable to work in either a windows 10 or 7 machine. Both machines say it's a Com Port error.
 

N9JIG

Sheriff
Moderator
Joined
Dec 14, 2001
Messages
4,451
Location
Far NW Valley
Is there a way to test the cable assembly to ensure it's not broken? Can't get the cable to work in either a windows 10 or 7 machine. Both machines say it's a Com Port error.
Did the cable work before? When I rebuilt my Windows 10 computer all I did was plug the cable in and it automatically installed the driver and it works fine. I have both the RadioShack 20-147 (Orange) and the GRE (Blue) cables and they both installed just fine without needing to download drivers.
 

ttprescott

Newbie
Joined
May 23, 2008
Messages
4
Location
Massachusetts
I have the orange one and it has always worked before. I honestly don't remember if I've used it since I upgraded my machine to W10. I'm stumped
 

ermin

Member
Joined
Dec 21, 2007
Messages
358
Location
Jacksonville Florida
Hello All

So I have been using this cable for over 10 years and also with Windows 10 with zero problems. After the Windows 10 Creators update the cable will not work and I still have the original driver CD but cannot get 10 to work with it.

Any suggestions or where I can get a driver for it that works with windows 10?

Thank you

Ermin
Hello All

Well. After a long and winding road and a big Thank You to Microsoft Community I have definitely found that this is caused by the Microsoft Founders update.

The Baofeng UV-5R cable started working after applying the driver update from Miklor about 10 times.

The Pro96 cable started working after using the driver at D2XX Direct Drivers (use the top choice with the release date of 2017-03-10 2.12.26 That is the only way I can get the 20-047 cable to work.

I also have a 3 month old RT systems cable for my Icom IC2730A which no matter what driver I use I cannot get it to work on any computer that has had the founders update.

Good Luck & 73

Ermin
 

fxdscon

¯\_(ツ)_/¯
Premium Subscriber
Joined
Jan 15, 2007
Messages
4,976
Did the cable work before? When I rebuilt my Windows 10 computer all I did was plug the cable in and it automatically installed the driver and it works fine. I have both the RadioShack 20-147 (Orange) and the GRE (Blue) cables and they both installed just fine without needing to download drivers.
Same here. Just finished a fresh clean install of Win10 on a new hard drive with all available updates including Founders update. Plugged in both my old 20-147 cable and the GRE blue version.

Win10 recognized both cables, downloaded and installed the correct drivers, and assigned a comport to them. I was up and running with Win500 within a matter of seconds. I didn't have to disable unsigned driver restrictions or any other work-around. It was truly plug and play.

Don't know why some are having problems, but the cables do work fine with fully updated Win10.

.
 

ermin

Member
Joined
Dec 21, 2007
Messages
358
Location
Jacksonville Florida
Same here. Just finished a fresh clean install of Win10 on a new hard drive with all available updates including Founders update. Plugged in both my old 20-147 cable and the GRE blue version.

Win10 recognized both cables, downloaded and installed the correct drivers, and assigned a comport to them. I was up and running with Win500 within a matter of seconds. I didn't have to disable unsigned driver restrictions or any other work-around. It was truly plug and play.

Don't know why some are having problems, but the cables do work fine with fully updated Win10.

.
It's gotta be a hardware thing. I have 2 laptops. 1 five years old and 1 one year old with the same problem. I have a 2010 desktop and everything works fine. All three have had the founders update.

Ermin
 

N9JIG

Sheriff
Moderator
Joined
Dec 14, 2001
Messages
4,451
Location
Far NW Valley
There might be some obscure version issue at play here too. They manufactured these cables over a period of time and there might be some older chipsets or perhaps a few counterfeits got mixed in the batches someplace.
 

ermin

Member
Joined
Dec 21, 2007
Messages
358
Location
Jacksonville Florida
There might be some obscure version issue at play here too. They manufactured these cables over a period of time and there might be some older chipsets or perhaps a few counterfeits got mixed in the batches someplace.
I wish that was the problem. I have the same problem with 4 cables
1 original 20-047 Pro96 cable
1 2 year old cable for a Baofeng UV-5R
1 1 year old cable for a Baofeng UV-82
1 1 month old cable from RT Systems for a IC-2730 Icom

ALL worked properly BEFORE the Windows 10 Founders update
ALL stopped working the day of the Windows 10 Founders update

I'm pretty sure it was the windows 1 update.

73

Ermin
 

N9JIG

Sheriff
Moderator
Joined
Dec 14, 2001
Messages
4,451
Location
Far NW Valley
Try doing the Creator Edition update, this will show Windows v1703. I know Windows has those drivers included.

I don't know much about Windows Founders edition.
 

ermin

Member
Joined
Dec 21, 2007
Messages
358
Location
Jacksonville Florida
Try doing the Creator Edition update, this will show Windows v1703. I know Windows has those drivers included.

I don't know much about Windows Founders edition.
Yes. It was the creator update. I've had the RT cable driver check about 6 times after the creators update
But no luck.

73

Ermin
 
Status
Not open for further replies.
Top