re running DSD in Ubuntu 12.04

Status
Not open for further replies.

gary123

Member
Joined
Sep 11, 2002
Messages
1,435
I have installed the Make patches mentioned in the 11.10 thread and the sound patch mentioned in the 10.10+ thread. DSD has installed correctly with no errors. I have run xoscope to confirm input and have good clean inputs at a good level.

the trouble I have is this error.

Code:
Error, couldn't open /dev/audio
ioctl reset error 
ioctl speed error 
ioctl stereo error 
ioctl setfmt error 
Audio In/Out Device: /dev/audio
SNDCTL_DSP_CHANNELS: Bad file descriptor

I have read all the threads I can but cant seem to get rid of it and have DSD run. The computer ran DSD with no troubles under Ubuntu 10.10. Can someoen with more UBUNTU experiance point me in the right direction to fix this.
 

troffasky

Member
Joined
Apr 19, 2012
Messages
27
/dev/audio doesn't exist in 12.04, at least by default, and possibly not at all. Neither Google nor DuckDuckGo will return sensible search results for "/dev/audio 12.04" so I'm not getting far with this.

Ideally, DSD needs porting to Pulseaudio, then it could be used with SDR, making it a whole lot more useful.
 

jshg46

Member
Joined
May 12, 2010
Messages
126
If you don't mind changing, There is a version of LinuxMint that works great with no modding. It is the Debian version if anyone is interested.
 

phophollety

Member
Joined
Oct 13, 2012
Messages
4
Well, I have the very same problem, use ubuntu 12.04 on my pavilion DV6, I've modified an PRO-95 to get the discriminator out, under alsa mixer, I connetr it to the input, which can be used as mic or line in, set it as line in under sound application and set no amplification, If i get the sound recorder, I can recorder without anyproblem the discriminator.

After some search, I've found the path is /dev/snd,

If I chante the path, I get the very same error:

root@Renan-HP:/dev/snd# dsd -i /dev/snd -o /dev/snd
Digital Speech Decoder 1.4.1
mbelib version 1.2.3
Error, couldn't open /dev/snd
ioctl reset error
ioctl speed error
ioctl stereo error
ioctl setfmt error
Audio In/Out Device: /dev/snd


If I command ls -li I get this:

root@Renan-HP:/dev/snd# ls -li
total 0
994 drwxr-xr-x 2 root root 60 Out 14 09:52 by-path
9609 crw-rw---T+ 1 root audio 116, 8 Out 14 09:52 controlC0
990 crw-rw---T+ 1 root audio 116, 7 Out 14 09:52 hwC0D0
989 crw-rw---T+ 1 root audio 116, 6 Out 14 09:52 hwC0D3
988 crw-rw---T+ 1 root audio 116, 5 Out 14 14:23 pcmC0D0c
987 crw-rw---T+ 1 root audio 116, 4 Out 14 15:34 pcmC0D0p
986 crw-rw---T+ 1 root audio 116, 3 Out 14 09:52 pcmC0D1p
985 crw-rw---T+ 1 root audio 116, 2 Out 14 09:52 pcmC0D3p
682 crw-rw---T+ 1 root audio 116, 1 Out 14 09:52 seq
681 crw-rw---T+ 1 root audio 116, 33 Out 14 09:52 timer

Alfer some googling and playing around with alsamixer on terminal, pcmC0D0c is the input, the capture and pcmC0D0p is the player, output, if I try to run dsd under these devices, I have this output.

root@Renan-HP:/dev/snd# dsd -i /dev/snd/pcmC0D0c -o /dev/snd/pcmC0D0p
Digital Speech Decoder 1.4.1
mbelib version 1.2.3
ioctl reset error
ioctl speed error
ioctl stereo error
ioctl setfmt error
Audio Out Device: /dev/snd/pcmC0D0p
ioctl reset error
ioctl speed error
ioctl stereo error
ioctl setfmt error
Audio In Device: /dev/snd/pcmC0D0c

And again, if I check under sound app, which lists the application capturing or playing audio, nothing is listed.

Tomorrow I'll try to buy an USB external soundcard.
 

nycap

Member
Joined
Mar 13, 2008
Messages
196
anyone ever have any luck getting dsd running on 12.04? i cant even get the dsd_audio.c file to patch
 

nycap

Member
Joined
Mar 13, 2008
Messages
196
yes i did. first i replaced the make files. then i patched the dsd_audio.c file. recompiled. turned off pulse audio. and now it works.

my soundcard:

lspci -v | grep -A7 -i "audio"
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
Subsystem: Dell Device 022f
Flags: bus master, fast devsel, latency 0, IRQ 46
Memory at fe9fc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd-hda-intel
 

wizworks

Member
Feed Provider
Joined
Feb 19, 2014
Messages
1
Location
Northbridge, MA
i got it working in 12.10.
Would you mind documenting for us exactly what you did to get this to work in Ubuntu?

Specifically, what code you changed in dsd_audio.c and any packages, etc you had to install?

This would be a big help to the ham radio community & Ubuntu users.

Best Regards,

John, K1WIZ
 

Krainium

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
10
Location
Pueblo West, CO
To get dsd to work in pulse audio versions of Linux, it is easiest to pipe the application through the padsp utility. padsp creates a "dummy" /dev/dsp device for dsd to use. The command then becomes something like this:

padsp dsd -i /dev/dsp -o /dev/dsp <and other switches you want>

~k
 

rick10

Member
Joined
Mar 27, 2004
Messages
12
Location
rick10
DSD with pulseaudio support

I modified DSD to use pulseaudio to avoid the hassle of padsp.
 

kb9mwr

Reddit Sucks Less
Joined
Apr 8, 2003
Messages
207
Location
Green Bay, WI
I get the same error (ioctl reset error) the first guy (gary) did even when I use padsp.

(Life was easier with OSS audio back in the CentOS 5 days)

Rick, can you share how you modified DSDto use pulseaudio?

Thanks
 
Last edited:
Status
Not open for further replies.
Top