SDR# Won't Install

ILjim

Member
Premium Subscriber
Joined
Sep 9, 2016
Messages
254
Location
Cook Co, IL
After I downloaded the new version of SDR#, I clicked on the Installer and I keep getting the message "AudioProcessor: Error downloading file". I never had this problem when I installed the previous versions. Anyone know why this is happening?SDRSharpNotInstalling.png
 

tango20k

Member
Joined
May 2, 2016
Messages
13
Hey ILJim,
this most likely relates to website repository error . so file is just not found on the website server or has been replaced with a newer one.
 

morfis

Member
Joined
Jan 24, 2004
Messages
1,050
With a couple of releases a day recently to add features and update telerik several plugins are causing even more errors than normal in that downloader. The pertson who supplies it has been made aware.
Discussion in posts at: [email]airspy@groups.io[/email] | Topics

Simple solution for now (always actually) is to use the actual release version and then only add the plugins you actually 'need' (some aren't needed any more due to changes in the programme and some seem unlikley to work but I've not seen any users list the problematic ones).
 

thewraith2008

Member
Joined
Nov 22, 2016
Messages
1,129
Most (Vasili's) plug-ins are sourced from rtl-sdr.ru, this website is currently down and is why the installer is failing.

As morfis said, only use the standard version of SDR#.
The number one problem SDR# will encounter will be from plug-ins.

The community plug-in package is a bit of a dis-service to SDR# as new users can't help themselves and install every plug-in.
They are not made aware that some of the plug-ins are quite old (and no longer maintained) and have become problematic with newer versions of SDR#. There is also the problem that some plug-ins may not be compatible with other plug-ins.

Manually installing plug-ins is not that hard.
Copy file/s to SDR# folder then edit 'Plugins.xml' and add the appropriate line for each plug-in. Done.
 
Top