• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

Streaming from Pi RTL-SDR to IceCast server (sound with interruption)

Status
Not open for further replies.
Joined
Sep 11, 2016
Messages
2
#1
Hello!

I've configured my RaspberryPi 3 with RTL-SDR according to this guide

Raspberry Pi RTL-SDR Broadcastify - The RadioReference Wiki

I have my own IceCast server.

After I've launch transmission I received sound from IceCast with interruption.

It is hard to explain, that's why I prepare this sound file
https://soundcloud.com/roman-koval/rtl-sdr-transmit-problem

From 0:02 to 0:14 should be normal tone signal.
From 0:15 to 0:24 should be normal speech "one, two, three, four ... ten "

It seems to me that this is problem with lame.
When I am trying to listen RTL-SDR directly like
rtl_fm -f 145000000 -M fm -s 190k -p 59 -r 48k - | play -t raw -r 48k -b 16 -e signed-integer - -c 1
it sound good.

LAME 32bits version 3.99.5

How can I fix this issue?
 
Joined
Sep 30, 2014
Messages
9
Location
WA
#2
This is the command I use to stream and it works great. I use ezstream though.

rtl_fm -f 155.6775m -l 70 -g 30 -s 12k -t 2 -E pad | lame -r -s 12 -m mono -b 16 --cbr --lowpass 4 - - | ezstream -c /etc/ezstream_bcfy.xml
 
Status
Not open for further replies.
Top