2 minute delay

ke4ldu

Member
Joined
Nov 4, 2009
Messages
38
Location
Taylorsville, North Carolina
With this new Broadcastify image, I have 3 feeds now on 1 pi. There use to be only about a 25 second delay from original transmission on the radio. Now it seems I have about a 2 min delay. Anyone know why?
 

krokus

Member
Premium Subscriber
Joined
Jun 9, 2006
Messages
4,917
Location
Southeastern Michigan
With this new Broadcastify image, I have 3 feeds now on 1 pi. There use to be only about a 25 second delay from original transmission on the radio. Now it seems I have about a 2 min delay. Anyone know why?
Is that delay consistent? It could have been a traffic load delay.
 
Joined
Jan 4, 2005
Messages
1,580
Location
Soledad, CA
I don't use broadcastify image with drakice. I use liquidsoap and my feeds are now 2mins delayed also from when I ran radiofeed on windows.
 

vagrant

ker-muhj-uhn
Joined
Nov 19, 2005
Messages
1,990
Location
California
I've been running a feed for over a year now. My stream typically has a 90 second delay. Sometimes after restarting it was shorter, but from time to time over the year when I checked it was about 90 seconds behind. I'm using Windows 10 and Broadcastify ScannerCast. The computer is new and I have 100 Mbps up and down, so it is not on my end. It was also around a 90 second delay when I was using a different provider with only 6 Mbps upload speed. With over 7000 live feeds to process, having some latency does not surprise me. Less delay would be nice for listeners, but hey...free stream for them. I advise of the delay in my feed description. I will probably switch over to the Pi image as things have progressed per that thread.
 

n3obl

Ø
Database Admin
Joined
Dec 19, 2002
Messages
1,232
Location
PA
There gonna be some delay inherent to sending over the net.
 

Deziel0495

Formerly ScanPEI
Database Admin
Joined
Feb 11, 2008
Messages
669
Location
PEI, Canada
My feed using RadioFeed is usually a 60-90 second delay. As mentioned above, after a restart it can be as short as 30-45 seconds but typically 60-90. I also mention this in my feed details. I don't mind the delay, others might.
 

bubbablitz

Member
Joined
Feb 15, 2016
Messages
30
I think this is deliberate and started around 2017 with the anti police riots. I've timed all of the local feeds that I'm in range of and, back then, the delay was about 25 seconds. Now, it's about a minute and a half. Then again, I could be wrong.
 

webstar22

policescanner.ca
Feed Provider
Joined
Dec 21, 2003
Messages
880
Location
Ontario, Canada
Its all based on buffer settings on the icecast servers, push a big chunk of data at the start so people don't buffer later on but you have a delay in the feeds, or push no buffer at the start and get a few seconds delay, but those with slow/poor data will buffer a lot while listening.

There also is nothing wrong with a delay when listening to a scanner online.
 
Top