• To anyone looking to acquire commercial radio programming software:

    Please do not make requests for copies of radio programming software which is sold (or was sold) by the manufacturer for any monetary value. All requests will be deleted and a forum infraction issued. Making a request such as this is attempting to engage in software piracy and this forum cannot be involved or associated with this activity. The same goes for any private transaction via Private Message. Even if you attempt to engage in this activity in PM's we will still enforce the forum rules. Your PM's are not private and the administration has the right to read them if there's a hint to criminal activity.

    If you are having trouble legally obtaining software please state so. We do not want any hurt feelings when your vague post is mistaken for a free request. It is YOUR responsibility to properly word your request.

    To obtain Motorola software see the Sticky in the Motorola forum.

    The various other vendors often permit their dealers to sell the software online (i.e., Kenwood). Please use Google or some other search engine to find a dealer that sells the software. Typically each series or individual radio requires its own software package. Often the Kenwood software is less than $100 so don't be a cheapskate; just purchase it.

    For M/A Com/Harris/GE, etc: there are two software packages that program all current and past radios. One package is for conventional programming and the other for trunked programming. The trunked package is in upwards of $2,500. The conventional package is more reasonable though is still several hundred dollars. The benefit is you do not need multiple versions for each radio (unlike Motorola).

    This is a large and very visible forum. We cannot jeopardize the ability to provide the RadioReference services by allowing this activity to occur. Please respect this.

APX 4000 Codeplug Update Failed

Not open for further replies.


Jul 4, 2005
Sioux City
First a couple of housekeeping items/background:

The company I work for is an authorized RX-only user on a Phase 2 public safety simulcast site that is part of a statewide system.

The APX 4000 was purchased new from a local Motorola shop.

It was initially programmed by the shop with later programming performed (about 6 months ago) by one of the LE agencies authorized on the system.

Although I've been a ham for 30 years and am proficient in programming certain brands of commercial radios, neither I nor the company I work for have access to any M programming software, cables or keyloaders. We did nothing to the radio.

Sorry, but I wanted to get all that out of the way to avoid unnecessary debate.

A coworker had the radio on his desk and says it was functioning normally. But, a little while later, noticed it was unusually quiet. He looked at the radio and the light on the front/top was flashing red and the display read "codeplug updt failed."

It's now quiet like a brick.

I did the usual power cycling and letting it sit without the battery installed. No joy.

I called the local comm center director and he advised that there were no OTAR/OTAP updates pushed and that our radio had not been stunned.

I took it to the Motorola shop, they looked at it for 10 seconds and, after asking me if I'd tried to hack it, they advised that it needed to go to depot.

My questions are:

Does it really need a four-week vacation at the depot?

Or, if the LE agency that last touched our radio had saved the personality and code plug (I think they did), could they re-upload those into the radio and clear the error?

And, the big one for me..... How the heck could this have even happened? Has anyone seen this before?



Super Moderator
Jan 7, 2001
Although anything is possible, I've never seen an APX spontaneously display codeplug update failed.

My money is on someone monkeyed with it.

As far as the original codeplug being able to fix it we don't know since we don't know what exactly is wrong with it, but it's worth a try.


Feb 24, 2001
Try to rewrite the plug to it. May take a few times but if it doesn't then the depot is its final destination.

Giving the update failed and several entities having systems on it it's possible one did try a over air update or someone yanked the usb in process of writing or turned it off or the battery died during a write not allowing it to update the plug and reboot properly.

No telling. It has the odd issue the latest firmware does if someone tools around with older illegal items on loose out there. So from what I have heard and you describe. Newer firmware is finicky with the older garage stuff. Probably why he asked if anyone tried to alter it by that or at least read or write and something happened during the codeplug read and write process.

Try to throw in the saved plug, like I said may take a few times but if it still fails to boot depot is its trip.


Jul 23, 2018
Kenosha, Wi

I re-read your timeline. It is possible the LE agency with authorization may, and I do mean MAY, have inadvertently loaded a codeplug on to the radio that switched on the OTAR. If that is the case, when the radio was in the charger and it RX the update, it may have had something go wrong...potentially really wrong.

I too would also attempt a re-prog. with a known good codeplug data or simply cloning from a known working twin.

If that does not work.......A trip to the great batwing Depot is in order.

Just my 2 cents.
Not open for further replies.