P25RX Firmware Updates / Testing

kruser

Active Member
Premium Subscriber
Joined
Nov 25, 2007
Messages
4,412
Location
West St Louis Cnty, MO
Using 2021-03-10_0709, I am still seeing a lot of missed voice channel requests on the BTConfig console display.
I also failed to mention but all the versions I've been testing sometimes have a hard time getting the info such as Site ID, RFSS, NAC, WACN etc. from the control channel. Once that info is populated, it does remain.
When I first went back to March 10 0709 version, BTConfig would not display any site info for almost a full minute even though it was showing the same signal strength and BLKS P/S that I mentioned in my earlier post above. This was seen on a site using 154.695 for the control channel.
I've seen this behavior on the VHF sites with several versions loaded on the P25RX.
Once it grabbed the site info and displayed it in BTConfig 0709, it started decoding audio packets again but does still have the missing packet problem as the newer versions it seems.
 
  • Like
Reactions: btt

Cheeseburgers

Member
Joined
Jan 9, 2018
Messages
348
_1850 seems to be doing well today. Two things...

1. Had the software glitch and stop giving info when in monitor mode... they it seems to have resolved itself and start working again.

2. I also took the time to modify my TG list in excel, and paring everything down similar to how I had my G4/G5 laid out. Seems to have helped... before I had allow unknown TGs which I only think complicated matters.

Good stuff Todd. Thanks for all your tireless effort to improve this little blue box for us.
 
  • Like
Reactions: btt

W4KRR

Member
Premium Subscriber
Joined
Apr 1, 2001
Messages
3,160
Location
Coconut Creek, FL
_1850 working here for several hours with no issues.

I like the buttons under the "Console" tab; "Follow TG" and "Skip TG". Correct me if I'm wrong, but the "Follow TG" button toggles between holding on the currently active talkgroup, and releasing it? And it seems you don't have to click on "Enter Commands" for it to work.
 
  • Like
Reactions: btt

btt

Active Member
Premium Subscriber
Joined
Mar 11, 2020
Messages
783
Location
Wa State
Using 2021-03-10_0709, I am still seeing a lot of missed voice channel requests on the BTConfig console display.
I also failed to mention but all the versions I've been testing sometimes have a hard time getting the info such as Site ID, RFSS, NAC, WACN etc. from the control channel. Once that info is populated, it does remain.
When I first went back to March 10 0709 version, BTConfig would not display any site info for almost a full minute even though it was showing the same signal strength and BLKS P/S that I mentioned in my earlier post above. This was seen on a site using 154.695 for the control channel.
I've seen this behavior on the VHF sites with several versions loaded on the P25RX.
Once it grabbed the site info and displayed it in BTConfig 0709, it started decoding audio packets again but does still have the missing packet problem as the newer versions it seems.
@kruser , can you give 2021-05-05_1833 a test and see if you notice any improvements for VHF?
 

kruser

Active Member
Premium Subscriber
Joined
Nov 25, 2007
Messages
4,412
Location
West St Louis Cnty, MO
@kruser , can you give 2021-05-05_1833 a test and see if you notice any improvements for VHF?
Well, I'm still seeing complete misses of entire conversations and/or missing the first second or so of some audio.
This is of course on the VHF system set to its control channel only.

I setup a GRE model and a Uniden 996XT and they both decoded all voice traffic just fine while the P25RX sat there and kept scrolling the console showing a BLKS PS range of 20 to 41 while the two scanners were playing the voice channel audio. I don't recall the BLKS P/S range being that wide before unless I just missed it in the past.

Of course the P25RX does randomly detect voice traffic and will start decoding the audio a second or two after the voice traffic had started. And then at other times, the P25RX decodes the entire voice traffic just fine.
The sites signal level is showing a nice -66 dBm signal level the entire time and the Sync Status lines are nice and straight while the control channel is at rest but do become broken some when voice traffic is being decoded.
The attached screenshot show the signal insights screen. The red and yellow areas on the upper green line are periods where the P25RX was decoding audio.
When active voice packets are being missed or when the control channel is idle with no voice traffic, both the red and white lines are nice and flat all the way across.

Hopefully the screenshot will make it and be large enough to see!

BTConfig 2021-05-05_1833.png
 
  • Like
Reactions: btt

Cheeseburgers

Member
Joined
Jan 9, 2018
Messages
348
Still getting a lot of random drop offs in the newest experimental. Audio is perfect and then all of a sudden it just stops during a conversation or voice call.
 

btt

Active Member
Premium Subscriber
Joined
Mar 11, 2020
Messages
783
Location
Wa State
Still getting a lot of random drop offs in the newest experimental. Audio is perfect and then all of a sudden it just stops during a conversation or voice call.
Are you seeing "$TDMA voice timeout" or "$TDMA lost signal" messages in the console when this happens?
 

btt

Active Member
Premium Subscriber
Joined
Mar 11, 2020
Messages
783
Location
Wa State
Try 2021-05-07_0913 for the early drops. This is a change that was removed recently due to all the recent audio issues. Should be getting back to something that is working good again I hope.
 

goldmyne99

Member
Joined
Jul 23, 2018
Messages
46
Testing 05 07 0913.

Priority Interupt does not appear to be working in this release on Phase 1 for me.
Status message area does say TG Pri interrupt, but audio stays on lower priority TG.

Console messages also show the TG Pri interrupt but the ->(voice) message stays with the lower priority TG.

Allow TG Pri Int is checked on Advanced tab. I also wrote Config to P25RX.

Had been running 04 30 0922 with no issues with Pri Int. It worked very well.
 
  • Like
Reactions: btt

turnpike61

Ham and Electronics hobbyist since 1977.
Premium Subscriber
Joined
Aug 15, 2010
Messages
60
Location
Virginia
Testing 05-07:0913 - still patchy dropped words and comms - even on stronger sites.

I've noticed before what sounds like signals being decoded, but dropping below what might be an internal squelch level. I feel like I would miss less if I had an option to set the "squelch" a little closer to the noise level, but of course no control exists for that.

May not be relevant - but that's what it sounds like.
 

btt

Active Member
Premium Subscriber
Joined
Mar 11, 2020
Messages
783
Location
Wa State
Just got back from taking 2021-05-07_0913 for a test drive via Bluetooth. I have the small helical mag-mount taped to the receiver with double-sided tape. Stuck it in the glovebox. I had to take a trip to the hardware store to buy a handsaw. A tree decided to drop a big branch right in front of the antenna for the internet service. A reminder that sometimes the best way to fix a radio problem is to cut down a tree (or at least part of one). The test drive went very well. I think the recent changes are very close to being a stable release. I need to figure out the issues in the previous posts here, but the audio is very good here. I had zero issues even in the bad simulcast areas. Bluetooth is no longer dropping the ending audio of the conversation.

@goldmyne99 I will look into the TG priority interrupt issue a little later and see if I can figure it out. @turnpike61, are you monitoring a VHF system?
 

turnpike61

Ham and Electronics hobbyist since 1977.
Premium Subscriber
Joined
Aug 15, 2010
Messages
60
Location
Virginia
What was the last version that worked well for you on the STARS system? I will try to look at the differences since then.
I wouldn't change anything - as I played with settings, I forgot your admonition about turning off the TG Priority, and had it turned on again. I think what I was seeing was the result of PTT without audio interrupting those channels. I will continue to monitor, but this version seems clean now that I stopped that.
 
Top