ProScan in VirtualBox - can't connect to scanner

mcouture87

Member
Premium Subscriber
Joined
Nov 25, 2005
Messages
13
I have a Uniden BCD996P2 scanner. I have a Linux machine so I setup VirtualBox and installed Windows 10 as a guest. I am able to see other USB devices within the Windows 10 guest like my webcam. However I cannot get ProScan to connect to the scanner. When I plug in the scanner to USB, I get the Windows notice that something was plugged in. I go into the USB settings in ProScan and I do an autoconnect and it shows COM5 available but it never communicates. If I go back into the USB settings, it will show "in use by this session" error....

Anybody get a Windows 10 Virtualbox guest to successfully run ProScan?
 

a417

!#
Joined
Mar 14, 2004
Messages
1,295
what enumerates in the Device Manager (in Win10, that is) when you "get the windows notice something was plugged in"? Do you have all USB devices allowed thru by a filter, or are you enabling them individually?
 

mcouture87

Member
Premium Subscriber
Joined
Nov 25, 2005
Messages
13
I have tried no filter and now I have a filter set for the Uniden.

If I try to connect my USB webcam, once I select that device in the guest, it just works.


In Device Manager under "Ports", I see "Uniden Serial Port"

In the Events tab I see:

Device USB\VID_1965&PID_001A\5&18f54cb7&0&2 was migrated.

Last Device Instance Id: USB\VID_1965&PID_001A\5&18f54cb7&0&2
Class Guid: {4d36e978-e325-11ce-bfc1-08002be10318}
Location Path:
Migration Rank: 0x0
Present: false
 

ka3aaa

Member
Premium Subscriber
Joined
Jan 27, 2008
Messages
538
Location
middletown, pa.
did you download and install the special driver that is required for the 996p2 and are you using the front usb port?
 

mcouture87

Member
Premium Subscriber
Joined
Nov 25, 2005
Messages
13
I do have the Uniden serial drivers installed and plugged into the front usb port....yes

I do have the VirtualBox Guest Additions installed too...
 

lwvmobile

Newbie
Joined
Apr 26, 2020
Messages
1
Just ran into a similar issue getting any USB device detection in Windows 7 in Virtualbox. Make sure to add your user account to the vbox group. Not sure if its the same type of issue or not, but it might be worth checking.

sudo adduser $USER vboxusers​

That all being said, after I got USB detection up and working properly, I never could get Zadig to install the correct driver for me but I suspect that was more to do with the older version of Windows 7 that I had an ISO for. Anyways, just thought i would suggest this to see if it helps any or not.
 
Top