Sentinel Windows 10 Delay

KenM37

Member
Premium Subscriber
Joined
Sep 24, 2006
Messages
43
Installed sentinel on my new windows 10 laptop. It has all the latest updates. Sentinel has the latest updates too. When I try to read or write to my SDS 100 there is a long delay, minutes, before it finally finds the radio. The icon just spins until finally it connects and the next menu pops up showing the radio. After that it appears to work normal. Does anyone have any thoughts or experienced something similar?
Thanks
KenM
 

jtwalker

Member
Joined
Dec 3, 2012
Messages
101
Location
Gettysburg, PA
I believe it's waiting for Windows to mount the removable mass storage, and nothing to do with Sentinel. Prove this by not running Sentinel and connecting your SDS100 and putting in mass storage mode. How long before the drive shows up in Windows Explorer?
 

KenM37

Member
Premium Subscriber
Joined
Sep 24, 2006
Messages
43
Yes it mounts the drive immediately and it is "readable" as drive "D". I also see in device manager it creates a "com port" (COM3). The Com port then becomes inactive and is hidden. It takes reliably 10 mins to be discovered by Sentinel.
 

KenM37

Member
Premium Subscriber
Joined
Sep 24, 2006
Messages
43
UPDATE: I got this working finally. I went through all the windows updates and double checked that installation "took" successfully. I'm not sure which one did it but I found a problem with a .NET update and a driver update. I believe it was the driver.. I had a new 1TB portable usb drive that installed its own driver. i uninstalled it and ran windows update. After rebooting everything seemed to work properly.
Thanks
 
Top