PSR-800: errors/issues after upgrade

AuntEnvy

Member
Joined
Nov 27, 2006
Messages
1,081
Location
Central New York
Hello all ~ I'm wondering if anyone has started to see any issues with the 800 legacy upgrade from Whistler...

I did the upgrade a few months ago and recently started getting keypad problems ie. having to press whatever key I was attempting to do something with several times before it would register/work. I haven't gotten it dirty or spilled anything on it as it sits in my room and I don't take it anywhere. I suppose it could be the humidity ..? Also, a few times now I've come up to check the unit and it has shut down and shown error codes. I have seen this a few times over the years so I didn't actually check the error code number. Usually, I've simply cycled power or re-installed the sd card etc. and it would continue working as normal. This time it keeps doing it. I'll have to make sure I get the code when it does it again.

Just curious if anyone has been having the same problem or if this might just be another bad/worn out micro card again... Thank you for any help and advice.
 

tvengr

Active Member
Joined
Feb 10, 2019
Messages
4,082
Location
Baltimore County, MD
Replace the SD card first to eliminate any other possibilities. You can try reformatting the card. It helps to have a spare card with the same programming to make a quick swap for troubleshooting. The SD card is the weakest link in the chain and can cause multitudes of weird problems.
 

AuntEnvy

Member
Joined
Nov 27, 2006
Messages
1,081
Location
Central New York
Thank you tvengr... I agree with the card aspect. Seems that I've done that a few times over the years. That was going to be my next solution but I wanted to know if anyone had any such problems or if this was just another common issue.
 

repairman222

Member
Joined
May 24, 2021
Messages
24
Location
Missouri
Hello all ~ I'm wondering if anyone has started to see any issues with the 800 legacy upgrade from Whistler...

I did the upgrade a few months ago and recently started getting keypad problems ie. having to press whatever key I was attempting to do something with several times before it would register/work. I haven't gotten it dirty or spilled anything on it as it sits in my room and I don't take it anywhere. I suppose it could be the humidity ..? Also, a few times now I've come up to check the unit and it has shut down and shown error codes. I have seen this a few times over the years so I didn't actually check the error code number. Usually, I've simply cycled power or re-installed the sd card etc. and it would continue working as normal. This time it keeps doing it. I'll have to make sure I get the code when it does it again.

Just curious if anyone has been having the same problem or if this might just be another bad/worn out micro card again... Thank you for any help and advice.
I received my PRS 800 from Whistler and it was upgraded to a WS1080. Has been flawless . Probably your sd card. Make so it has all the new updates and firmware. Also if you put in a new sd card you need to format the sd card.
 

Wackyracer

Member
Premium Subscriber
Joined
Feb 18, 2016
Messages
1,507
Probably the keypad is worn out. You can try reinstalling the firmware and see if that helps. I do not see replacing the sdcard helping , but I have been wrong before. Good Luck!
 
Top