• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

TwoToneDetect New TwoToneDetect in the works - Python based

yoseffby

Newbie
Joined
May 28, 2017
Messages
2
What you are describing sounds basically normal. The audio level should be low when no one is talking and high when there is an active transmission on the frequency being monitored. You want the squelch slider adjusted slightly above the base level
I apologize if I wasn't clear, essentially when the system boots the level is very low, once the first transmission comes through it equalizes to where I have the squelch set and stays there but I have also seen times where it stays very high. None of these cases are during actual radio traffic. So the issue is unpredictable base audio levels. I feel like its a software issue since it is repeating with every boot cycle. Thanks for your reply
 

DC31

Member
Premium Subscriber
Joined
Feb 19, 2011
Messages
1,100
Location
Massachusetts
I apologize if I wasn't clear, essentially when the system boots the level is very low, once the first transmission comes through it equalizes to where I have the squelch set and stays there but I have also seen times where it stays very high. None of these cases are during actual radio traffic. So the issue is unpredictable base audio levels. I feel like its a software issue since it is repeating with every boot cycle. Thanks for your reply
Do you have RealVNC activated on your pi? If so, send me an invite at jim.burnham.gm@gmail.com so I can take a look.
 

jhsands

Member
Premium Subscriber
Joined
Sep 6, 2006
Messages
233
Location
Texarkana, Arkansas
I apologize if I wasn't clear, essentially when the system boots the level is very low, once the first transmission comes through it equalizes to where I have the squelch set and stays there but I have also seen times where it stays very high. None of these cases are during actual radio traffic. So the issue is unpredictable base audio levels. I feel like its a software issue since it is repeating with every boot cycle. Thanks for your reply
Check your audio cable ground. Is your audio cable grounding through the Pi? Is it a scanner or radio? Are you using a discriminator or speaker out?

I use PM400s with pins 11 and 7 for my audio in. CM300s use the same pins.
 

ahaas

Member
Joined
Apr 16, 2011
Messages
20
I'm having trouble starting TTD from a .desktop config file. I'm using this to place in the ~/.config/autostart/ directory to have TTD start with boot. Upon debugging why it won't work I'm running into the program bailing out when "instance_id" is "undefined" per terminal logs. I've tried setting the instance_id in the GUI and in the config.cfg file. Any ideas? If I execute the executable directly by hand it loads up just fine.
 

aaknitt

Member
Premium Subscriber
Joined
Aug 27, 2005
Messages
1,134
I'm having trouble starting TTD from a .desktop config file. I'm using this to place in the ~/.config/autostart/ directory to have TTD start with boot. Upon debugging why it won't work I'm running into the program bailing out when "instance_id" is "undefined" per terminal logs. I've tried setting the instance_id in the GUI and in the config.cfg file. Any ideas? If I execute the executable directly by hand it loads up just fine.
I've not used the .desktop config file method before to autostart, but it sounds as if TTD may be trying to run from a location other than where the config.cfg file is located? When I run .sh scripts for autostart I first change to the TTD directory (cd /home/pi/TTD) before running. I'm not sure if you need to do something similar with the .desktop method or not.

Andy
 

ahaas

Member
Joined
Apr 16, 2011
Messages
20
I've not used the .desktop config file method before to autostart, but it sounds as if TTD may be trying to run from a location other than where the config.cfg file is located? When I run .sh scripts for autostart I first change to the TTD directory (cd /home/pi/TTD) before running. I'm not sure if you need to do something similar with the .desktop method or not.

Andy
Thank you! Here I am all night resorting to a symlink at one point and you reminded me I could just right a shell script and have it launch the executable at boot.
 
Top