TwoToneDetect New TwoToneDetect in the works - Python based

jhsands

Member
Feed Provider
Joined
Sep 6, 2006
Messages
355
Location
Texarkana, Arkansas
For those that are seeing this issue, is it Windows, Pi, or both? Does the tone detection still function when this occurs?

FYI I've identified a bug that can cause TTD to crash after it's generated a large amount of audio files...typically several weeks of operation on a busy system without restarting. I have a fix in testing now that should be out soon. One symptom of this issues is that the web page doesn't work, but neither does tone detection. If there's a different issue where the web page doesn't work but tone detection does, that's something different I'll need to look into.

Andy
Tone detection works fine; 404 error.
 

aaknitt

Member
Feed Provider
Joined
Aug 27, 2005
Messages
1,232
Same. As far as I know it's working fine in the background but when trying to bring up the webpage to manage settings I get a 404 error. Usually restarting the program or the PC solves it.
Ok. And are you attempting to open it by clicking on the icon in the system tray or by going to the URL some other way (bookmark or manually entered)? One thing to try is manually incrementing the port number in the URL by one in the browser address bar...if the port that TTD is trying to use is blocked for some reason during startup it will attempt to try the next port. Wouldn't really explain what's going on if it was working and then stopped though.

Andy
 

Deziel0495

Formerly ScanPEI
Database Admin
Joined
Feb 11, 2008
Messages
658
Location
PEI, Canada
Ok. And are you attempting to open it by clicking on the icon in the system tray or by going to the URL some other way (bookmark or manually entered)? One thing to try is manually incrementing the port number in the URL by one in the browser address bar...if the port that TTD is trying to use is blocked for some reason during startup it will attempt to try the next port. Wouldn't really explain what's going on if it was working and then stopped though.

Andy
I get it by clicking the icon in the taskbar to open the management page, not sure about the others. It is using the default port as far as I know and working fine in the background. Just when I try to open it I get the 404 error but it keeps working to my knowledge. A simple force restart of the program usually fixes it.
 

jhsands

Member
Feed Provider
Joined
Sep 6, 2006
Messages
355
Location
Texarkana, Arkansas
Ok. And are you attempting to open it by clicking on the icon in the system tray or by going to the URL some other way (bookmark or manually entered)? One thing to try is manually incrementing the port number in the URL by one in the browser address bar...if the port that TTD is trying to use is blocked for some reason during startup it will attempt to try the next port. Wouldn't really explain what's going on if it was working and then stopped though.

Andy

Code:
TCP    0.0.0.0:8080           0.0.0.0:0              LISTENING
[TTD71.exe]
Code:
http://192.168.43.36:8080/index.html

Error: 404 Not Found
Sorry, the requested URL 'http://192.168.43.36:8080/index.html' caused an error:

File does not exist.
Restart the program and all is fine. I've never seen an icon in the system tray... running 71c.
 

WebsterEMA

Member
Feed Provider
Joined
Sep 15, 2017
Messages
31
I'm using it on Windows, and I'm just clocking on the tray icon. Or if the main screen is already up, I'm hitting one of the configuration buttons.
 

mattnelson26

Member
Feed Provider
Joined
Mar 20, 2007
Messages
379
Location
Hopkins, Minnesota
Good morning all I have multiple two tones working. One is working fine no issues and another with different cities and some of the same but womt send to address and I copied and paste just changed to a and b numbers. I checked the log and says it sent no errors
 

DC31

Member
Feed Provider
Joined
Feb 19, 2011
Messages
1,340
Location
Massachusetts
Your working TTD is sending individual emails and the non-working is trying to send a group email. Have you tried individual?
 

Mark181

Member
Feed Provider
Joined
Jun 18, 2020
Messages
23
Location
Ocean County, NJ
Strange how he is unable to send the emails as BCC. I use that for all of my TTD scripts that I'm running.

I find it much faster and much less likely for Gmail to get pissed at you, lol.
 

Deziel0495

Formerly ScanPEI
Database Admin
Joined
Feb 11, 2008
Messages
658
Location
PEI, Canada
Does anyone know if TTD could use this tone as an AB tone?

I haven't played around with it much but looking at possibly capturing pages on our P25 trunked system and they frequently use this alert tone.

 

DC31

Member
Feed Provider
Joined
Feb 19, 2011
Messages
1,340
Location
Massachusetts
Ok, so that appears to be an 800/1500 hz tone set with two cycles per second. Thus, each tone is approximately .25 sec long. Try both tonelengths of 2. It may get it but won’t be very reliable

make that 0.2 tonelength
 

Mark181

Member
Feed Provider
Joined
Jun 18, 2020
Messages
23
Location
Ocean County, NJ
When is the next version of TTD being released, and might I request a feature that will make it easier to add or remove multiple people to multiple different tone lists in one action?
 

cpg178

Member
Premium Subscriber
Joined
Sep 7, 2014
Messages
67
Location
Lackawanna, PA
When is the next version of TTD being released, and might I request a feature that will make it easier to add or remove multiple people to multiple different tone lists in one action?
TTD was bought by I am Responding so unless you pay the big bucks your stuck with what they have now I am pretty sure.
 
Top