Struggling to get RTL-SDR feed to work. Possible -E pad issue

Status
Not open for further replies.

n0rc

Member
Feed Provider
Joined
Oct 28, 2009
Messages
17
Location
Shawnee, KS
I'm struggling to get my RTL-SDR feed using a RaspberryPi to work using rtl_fm. I think the issue is with the '-E pad' option. I have configured a fresh installation of the Raspian Jessie with Desktop, version July, 2017 per the Raspberry Pi RTL-SDR Broadcastify WikiPage. I've made sure to use the Osmocom release of RTL-SDR. The issue is, when I turn my squelch up so I no longer have noise, the ezstream feed drops out. If I leave my squelch down, it will keep streaming.

I'm starting the feed using the following commands:
Code:
/usr/local/bin/rtl_fm -d 0 -M fm -f 145.47M -p 0 -l 275 -g 48 -t 2 -E pad -s 12k | /usr/bin/lame -r -s 12 --resample 22.05 -m m -b 16 --cbr --lowpass 4 - - | /usr/bin/ezstream -c /etc/ezstream_bcfy.xml > /home/pi/bcfy2.log 2>&1
Yes, I left the ampersand off at the end, I'm doing this for testing so I can easily kill everything. I've tried it with the ampersand on the end of the line, just to be thorough even though it shouldn't make any difference, with no change.

Can anyone with a working configuration pass on their pro-tips? I've seen in several threads that using the RTL-SDR dongle and a RaspberryPi does actually work. I just cannot figure out why I am a unique snowflake and can't get it working.
 

DC31

Member
Feed Provider
Joined
Feb 19, 2011
Messages
1,271
Location
Massachusetts
I'm struggling to get my RTL-SDR feed using a RaspberryPi to work using rtl_fm. I think the issue is with the '-E pad' option. I have configured a fresh installation of the Raspian Jessie with Desktop, version July, 2017 per the Raspberry Pi RTL-SDR Broadcastify WikiPage. I've made sure to use the Osmocom release of RTL-SDR. The issue is, when I turn my squelch up so I no longer have noise, the ezstream feed drops out. If I leave my squelch down, it will keep streaming.

I'm starting the feed using the following commands:
Code:
/usr/local/bin/rtl_fm -d 0 -M fm -f 145.47M -p 0 -l 275 -g 48 -t 2 -E pad -s 12k | /usr/bin/lame -r -s 12 --resample 22.05 -m m -b 16 --cbr --lowpass 4 - - | /usr/bin/ezstream -c /etc/ezstream_bcfy.xml > /home/pi/bcfy2.log 2>&1
Yes, I left the ampersand off at the end, I'm doing this for testing so I can easily kill everything. I've tried it with the ampersand on the end of the line, just to be thorough even though it shouldn't make any difference, with no change.

Can anyone with a working configuration pass on their pro-tips? I've seen in several threads that using the RTL-SDR dongle and a RaspberryPi does actually work. I just cannot figure out why I am a unique snowflake and can't get it working.
You are not a unique snowflake. I think that the unique snowflakes are the ones who HAVE made it work. I am sure that you have found the thread but follow Jack's trials in this thread: http://forums.radioreference.com/br...broadcastify-using-rtl-sdr-3.html#post2745405. He has many good pointers such as using the keenerd fork rather than the osmocom to get the E pad option to function. The Wiki on the subject ended up referencing the wrong fork, i believe. Jack tells you how to test to see that you have the correct one.

Myself, i have wasted endless hours trying to make it work and have given up at least five times. Still not completely successful. I can get it to stream but not nearly the quality of a conventional scanner stream.
 

n0rc

Member
Feed Provider
Joined
Oct 28, 2009
Messages
17
Location
Shawnee, KS
Thanks for the tip DC31.

He has many good pointers such as using the keenerd fork rather than the osmocom to get the E pad option to function.
I swear I was using the keenerd fork originally. On some other forums, I've seen use osmocom instead of keenerd. I'll try a fresh install with keenerd and see what happens.

Per Jack's reply:
Folks, I haven't tested my instructions with a RPi3 - this was all done with a RPi2 using the image that I provided in the Wiki link.
If changing forks does not work, I'll ditch the RPi3 for now and revive my RPi2, who's death caused me to re-attempt this. I'll see if I can recreate his success.
 
Last edited:

JACK26

Member
Joined
Dec 7, 2016
Messages
298
Location
Milpitas, CA
iF you're having a problem with the -E pad option that keeps you live on Broadcastify, go back and make sure that the rtl-fm version you have installed is the keenerd fork from here:
https://github.com/keenerd/rtl-sdr

ps: this problem has nothing to do with rpi2 versus rpi3 but you are better off having the latest version raspberry pi .

pps: I too thought I originally installed the keenerd fork and not successful. Try it again it will eventually work :).
 
Last edited:

JACK26

Member
Joined
Dec 7, 2016
Messages
298
Location
Milpitas, CA
Latest struggle with linux script, why does this not work? :)

sudo rtl_fm -d 1 -f 482.8624M -s 16000 -g 29.7 \
-p 2 -l 95 -t 10 -E dc -E pad | \
sox -v 0.95 -t raw -r 16000 -b 16 \
-e signed -c 1 - -t .mp3 -c 1 -C 64 \
- sinc -n 3000 280-3.5k : - sinc -n 1000 325-55 |\
sudo /usr/bin/ezstream -q -c /etc/Ezstream \
sudo rtl_fm -d 0 -f 460.624M -f -s 16000 -g 28.0 \
-p 2 -l 95 -t 10 -E dc -E pad | \
sox -v 0.95 -t raw -r 16000 -b 16 \
-e signed -c 1 - -t .mp3 -c 1 -C 64 \
- sinc -n 3000 280-3.5k : - sinc -n 1000 325-55 |\
sudo /usr/bin/ezstream -q -c /etc/Ezstream2

I can divide the two tasks into 2 seperate tasks and it works fine, but combining these tasks in one script file is not working. Any comments are welcome :)

Sorry if this is a duplicate post :)
 
Last edited:

DC31

Member
Feed Provider
Joined
Feb 19, 2011
Messages
1,271
Location
Massachusetts
Latest struggle with linux script, why does this not work? :)

sudo rtl_fm -d 1 -f 482.8624M -s 16000 -g 29.7 \
-p 2 -l 95 -t 10 -E dc -E pad | \
sox -v 0.95 -t raw -r 16000 -b 16 \
-e signed -c 1 - -t .mp3 -c 1 -C 64 \
- sinc -n 3000 280-3.5k : - sinc -n 1000 325-55 |\
sudo /usr/bin/ezstream -q -c /etc/Ezstream \
sudo rtl_fm -d 0 -f 460.624M -f -s 16000 -g 28.0 \
-p 2 -l 95 -t 10 -E dc -E pad | \
sox -v 0.95 -t raw -r 16000 -b 16 \
-e signed -c 1 - -t .mp3 -c 1 -C 64 \
- sinc -n 3000 280-3.5k : - sinc -n 1000 325-55 |\
sudo /usr/bin/ezstream -q -c /etc/Ezstream2

I can divide the two tasks into 2 seperate tasks and it works fine, but combining these tasks in one script file is not working. Any comments are welcome :)

Sorry if this is a duplicate post :)
It looks like you have run your two tasks together without anything separating them. In your previous posts you have a pipe between the two tasks, in this one you don't. I don't really understand how it would work with a pipe, either, but apparently it does. I woukd try a semicolon as a separator. In linux that tells it to complete the first task and if that is successful to run the next one.
Good luck.
 

JACK26

Member
Joined
Dec 7, 2016
Messages
298
Location
Milpitas, CA
It looks like you have run your two tasks together without anything separating them. In your previous posts you have a pipe between the two tasks, in this one you don't. I don't really understand how it would work with a pipe, either, but apparently it does. I woukd try a semicolon as a separator. In linux that tells it to complete the first task and if that is successful to run the next one.
Good luck.
I tried that and so far this problem is a mystery. I tried running two separate .sh files to start the two sdr sticks in separate threads and no luck. The only thing that works is to open two separate command windows and start the two scripts manually.

First time I tried this it had no problem. I am beginning to think the rpi3's os is corrupted and may need to start from scratch.
 

DC31

Member
Feed Provider
Joined
Feb 19, 2011
Messages
1,271
Location
Massachusetts
I tried that and so far this problem is a mystery. I tried running two separate .sh files to start the two sdr sticks in separate threads and no luck. The only thing that works is to open two separate command windows and start the two scripts manually.

First time I tried this it had no problem. I am beginning to think the rpi3's os is corrupted and may need to start from scratch.
Again, remember who I am...

Both commands are trying to play to and from stdin and stdout. Can you have two processes simultaneously using stdin and stdout?
 
Status
Not open for further replies.
Top