Alpha Tag Synchronization Issue

Status
Not open for further replies.

SamAltenberger

Member
Premium Subscriber
Joined
Apr 1, 2013
Messages
8
Location
Seattle, WA
:confused: Greetings all,

I have a question regarding alpha tags on a Broadcastify feed. I currently stream the Seattle Fire feed on Broadcastify (the "Broadcasting Alpha Tags" option is selected), using a Uniden BC346XT scanner (latest firmware 1.05.00) connected to a computer running Windows 10 Pro (latest deferred version 1511) and ProScan (lastest version 11.5). The alpha tags are displayed as:
Code:
[Radio ID] - [Talkgroup Name]
I had previously used both ScannerCast and RadioFeed to stream the feed to Broadcastify, and it appears that this issue has occured while using all three server programs. It appears that on the client side, there is consistently a considerable delay/offset between the live audio being streamed and the alpha tags being displayed - often they do not correspond. This appears to be the case with the two methods I know of viewing the alpha tags: Using the iTunes option or the 5-0 Radio Police Scanner mobile app. On the server-side ProScan application, the alpha tags line-up exactly with the live audio coming from the scanner, so I think the problem is somewhere between ProScan and Broadcastify rather than between the scanner and ProScan. I have tried restarting all components of the system (the scanner, computer, router, feed) and that appears to have not done anything.

It is worth noting that there is about a 30-second delay between the live scanner audio and the streamed audio on the client-side. I assume that this delay is consistent for all Broadcastify feeds and that the alpha tags should have the exactly same delay in order to correspond with the streamed audio. Since alpha tags are nearly useless if they are offset from the audio they represent, I would greatly appreciate any insight or suggestions in order to synchronize the audio and alpha tags for my feed.

I have attached a PDF file of the ProScan database for this scanner in case it's helpful at all for diagnosing this issue. Thank you! :)
 

Attachments

Last edited:

ProScan

Member
Premium Subscriber
Joined
Jul 2, 2006
Messages
3,526
Location
Ontario, Calif.
Hi Sam,
The metadata or text tags is embedded in the mp3 stream at various intervals depending on the Source software. 1000 byte intervals using ProScan or RadioFeed. Broadcastify uses a special Icecast server version. I don't think the Icecast server removes the metadata at one position and reinserts at another position. In other words, the Icecast server passes the audio through to the clients connected to the server. There is a delay in the Icecast server but the metadata is in sync at the Icecast server. The client audio player produces the most delay with the built in latency/network buffer. I believe any out of sync metadata is caused by the audio player method of extracting the metadata. The audio player should extract the metadata after the network buffer but if they do it before the network buffer, that will cause an out of sync condition. So I would focus on the end point (audio player) to be the culprit.

{edit} BTW It's alway nice to look at the pdf and html files of the database. If you want to remove the header and footer generated by the Printer engine, go to the Printer Page Setup and change the Header and Footer section to Custom and then delete what's inside the text boxes.
 
Last edited:

alabamarailfan

Member
Premium Subscriber
Joined
Jan 6, 2009
Messages
152
Hello Sam,
I would tend to agree with ProScan. I am also a feed provider and have seen some odd skewing between alpha-tags and audio with some apps. However, using ScannerRadio on Android and Winamp on Windows, I have seen very good alignment of the alpha-tags with the audio. I haven't used either of the apps you mention so I can't comment on their performance. Hope this information helps!

[Edit] Forgot to mention, I use RadioFeed on all the audio feeds I manage.
73!
 

BlueDevil

Member
Premium Subscriber
Joined
May 5, 2010
Messages
722
Location
WA
I understand the concept here but I am not exactly sure wha the "Source Software" is. I am running both ProScan and Radio Feed for multiple different feeds that I manage and have never been able to get the Alpha tags to sync up.
 
Status
Not open for further replies.
Top