Bad Reception

Status
Not open for further replies.

Mg32968

Member
Joined
Jan 12, 2010
Messages
4
Location
Florida
I am having a problem with my radio reception. I thought it was a bad connector at the back of the radio so I replaced it. That did not help. While I was reconnting it I noticed that the reception got better when I held the plug close to the socket and went away when it touched. I got better reception when I taped the shield and connected the center. I checked the wire and antenna with an OHM meter and verified the shield has a good ground and the center lead is open to ground. If anyone can help me with this strange problem I sure would appreciate it.
 

Mg32968

Member
Joined
Jan 12, 2010
Messages
4
Location
Florida
The antenna appears to be normal and nothing has been done to it or near it that would make me suspect that it has been damaged. Is it possible the problem is in the radio?
 

Mg32968

Member
Joined
Jan 12, 2010
Messages
4
Location
Florida
I will jumper the antenna to the ground plane and check it with an OHM meter. Thanks for your help.
 

k9rzz

Member
Joined
Dec 12, 2005
Messages
3,162
Location
Milwaukee, WI
The antenna appears to be normal and nothing has been done to it or near it that would make me suspect that it has been damaged. Is it possible the problem is in the radio?
Well, you said that you had reception at times, so that gave me the impression that you thought the radio was okay.

Antenna connections go bad even if it 'looks okay'.

Just for kicks, clue us in on what frequency/band/radio/antenna we're talking about so we don't have to guess.
 

Mg32968

Member
Joined
Jan 12, 2010
Messages
4
Location
Florida
It is actually an AM FM car stereo. I know thats not what you guys are into but I figured if anybody knew about antennas it would here. The antenna is internal to the back window and I can't get to the connections without taking out the rear seat and the deck by the window. I do apprieate you willingness to help! Thanks
 
Status
Not open for further replies.
Top