Pro-668 Com Port issue

Status
Not open for further replies.

humblegeo

Member
Premium Subscriber
Joined
Jan 5, 2017
Messages
79
Location
Humble, Texas
Has anyone with this scanner had the com port fail? Used to be anytime I plugged in my 668 to the computer the led light on the scanner would stay on all the time, It was programed to do that under settings. Now when I plug in the scanner to the computer the scanner led never comes on and when I try to connect to the scanner thru IScan program it doesn't ever detect scanner. I've had this scanner maybe 6 months and it has always worked very well with the iscan software program until just recently. I tried several other cables and even ordered a brand new cable but that didn't fix the issue. It's not the cable. When I check Device Manager and look under Universal Serial Buss controllers or devices I don't see the pro668. Can I try and reload the driver?? Not sure how. The scanner is still very usable as is since I can still do all the programming I need to with Iscan and the micro SD Card and can recharge batteries with external charger. But now I can't send it into whistler for ws-1080 conversion since the com port isn't working and I can't do any firmware updates.

Any suggestion on how to verify for sure that my com port is shot?
Appreciate any help at all
Larry G
 

ScannerSK

Member
Joined
Mar 6, 2005
Messages
1,163
Location
Gilcrest, CO
Personally, I would begin by opening Device Manager on your computer and verify whether anything changes on the screen as you connect/disconnect your scanner to the computer. I would try several different USB ports on the computer. If something is being detected in Device Manager then it may be just a driver issue or a setting that needs changed somewhere.

If the above does not help, I would next try another computer to see if anything is detected in Device Manager as you connect/disconnect the scanner.

After this, trying another cable would be helpful if you have an extra.

As a last resort you can uninstall and reinstall the driver in Device Manager; if you cannot find the driver, you may have to select "show hidden devices" in the drop down menu.

Shawn
 
Last edited:

humblegeo

Member
Premium Subscriber
Joined
Jan 5, 2017
Messages
79
Location
Humble, Texas
After looking at the com cable connection on the radio with a magnifying glass, I'm pretty sure that some of the pins are slightly bent or pushed in. What a weak point on this radio. Why would they build a rugged robust radio like this and then put a piss poor com port connector on it? Granted I did use the heck out of the connector just about every time I used the radio. I can see now that was a big mistake. I should have just operated my radio on the battery and had an extra set of batteries charged up and ready to go. Instead I always had the radio either plugged into the computer usb port or hooked up to the ac power adapter. Guess I'll either just continue to use as is or have to send it in for repair if I can find someone that will work on these at a reasonable price. I really would like to convert to ws-1080 so I can get DMR. More and more are going DMR now seems like.
 

Wackyracer

Member
Premium Subscriber
Joined
Feb 18, 2016
Messages
1,372
What operating system? Windows 10 is known for making unsigned drivers not work after a windows update.

If windows 10 reinstall the COMPORT driver using the allow unsigned driver process.
 
Status
Not open for further replies.
Top