SDR# + Configuration Problem

Status
Not open for further replies.

OKCarl

Member
Joined
Jul 15, 2014
Messages
10
Location
Arlington Heights, Illinois
I am trying to run SDR# version 1.0.0.1313 on a Hewlett Packard laptop with four gigabytes of ram. My dongle is a NooElec R820T SDR & DVB-T NESDR Mini (RTL 2832U).

I can see the waterfall. I can see peaks. But all I hear is low frequency static punctuated by squeals and squeaks. When I click on the knobby 'Configure' button I get an error message reading- "Will be implemented later." What am I doing wrong? I suspect I am using the wrong configuration file or I put the configuration file in the wrong folder. One of my config files (SDRSharp.exe) weighs 7 kilobytes (actually 6.21 kilobytes) the other weighs in at 7 kilobytes (actually 6.14 kilobytes).

So far, I've tried swapping the Config files in and out of the SDR# folder. This effort makes no difference. Advice? Suggestions? I had an older version of SDR# up and running on my lap top last year.
 

rbm

Member
Joined
Jan 25, 2005
Messages
1,395
Location
Upstate New York
Did you select 'RTL-SDR / USB' in the drop down box under 'SOURCE'?

The config file must be in the folder you run the application from.

Rich

Edit: If all else fails, you can use this Config file to get started. (it's from v1313)
Just download the SDRSharp.txt file and rename it to SDRSharp.exe.Config

Edit again: Careful with that config file, I left the volume at max. ;)
 
Last edited:

OKCarl

Member
Joined
Jul 15, 2014
Messages
10
Location
Arlington Heights, Illinois
Thanks for taking an interest in my problem. (1) The SOURCE option that works for me is: SoftRock / Si 570. (2) Are you certain I should rename the text file: "SDRSharp.exe.Config" (omit the quotes)? I tried that. The file stays a text file (txt). Worse, it brings a crash down on my head. It does not morph to an executable.
 

rbm

Member
Joined
Jan 25, 2005
Messages
1,395
Location
Upstate New York
It is NOT an executable.
It is the configuration file.

The executable file is: SDRSharp.exe
The config file is: SDRSharp.exe.Config

Go to a DOS prompt, CD to that folder, and type this command: ren SDRSharp.txt SDRSharp.exe.Config
It must be named exactly that way.

The SDRSharp folder should contain the following files after you run the install.bat file.

Rich

Edit: If you're not comfortable using the DOS prompt, you 'could' just double-click on the install.bat file again and download all the files and start fresh.

And .. if you don't have the install.bat file, you can download the install zipfile here. It contains the three files you'll need to download and unpack all of the proper files in a folder named 'sdrsharp'.

SDR# | Software Defined Radio in C#

.
 

Attachments

Last edited:

LimaZulu

Member
Joined
Jul 7, 2011
Messages
181
If you managed to run your dongle try to adjust audio latency. I saw some laptops are sensitive to this. If you set lower latency there will be some squeaks. Start with 500ms and play up and down to find what suits best for you
 

rbm

Member
Joined
Jan 25, 2005
Messages
1,395
Location
Upstate New York
Thanks for taking an interest in my problem. (1) The SOURCE option that works for me is: SoftRock / Si 570. (2) Are you certain I should rename the text file: "SDRSharp.exe.Config" (omit the quotes)? I tried that. The file stays a text file (txt). Worse, it brings a crash down on my head. It does not morph to an executable.
SoftRock is the part that will be implemented later.

To run SDRSharp you should select ONLY ..... ( RTL-SDR / USB )

Rich
 

OKCarl

Member
Joined
Jul 15, 2014
Messages
10
Location
Arlington Heights, Illinois
Gentlemen! Thank You! Thank You! Thank you from the bottom of my left ventricle! My problems are solved! The guy who owns this website: http://www.rtl-sdr.ru/ somehow knew a village idiot would need help with SDR#. I installed his scanner plugin. Then I left clicked on the update button. The script not only updated my installation, it set all my input variables to the proper values. I am in business.
 
Status
Not open for further replies.
Top